forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: calling all developers, test release candidate
Date Fri, 13 Apr 2007 19:13:46 GMT
Ross Gardler wrote:
> Olivier Parent wrote:
>> here is my test run with the following environment:
>> OK    forrest war ... use your own full Jetty or Tomcat.
>>
>> Test with apache-tomcat-5.5.12 : OK overall
>> FAIL - the "plugins" link does not work (was OK when running with 
>> Forrest-Jetty)
>>      "/my-project/pluginDocs/plugins_0_70/index.html" could not be found
> 
> I'm now onto testing the war targets.
> 
> So will try and reproduce this error.

OK, I reproduced it.

(in tomcat 6, but that's not relevant to this issue)

The war works fine apart from this issue, at least as far as I can see.

The issue is caused by the fact that the war is mounted at 
localhost:8080/my-project rather than localhost:8080

The match in sitemap.xmap is:

<map:match pattern="pluginDocs/plugins_(.*)/index(|\.source).xml" 
type="regexp">

So it fails.

This is certainly an issue, but it is not one that is likely to actually 
affect users and is easy to fix in 0.8.1 or 0.9.

I don't see the need for a new RC1 for this issue.

Olivier, if you could add your report to the issue tracker that would be 
really helpful. I'll add it myself if you don't get around to it, but we 
prefer the person doing the legwork in discovering these bugs to get the 
credit for it in our tools.

The issue tracker is at http://issues.apache.org/jira/browse/FOR

Thanks again,
Ross

Mime
View raw message