forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: RC1 fails when plugins provide Java source
Date Fri, 13 Apr 2007 08:55:48 GMT
Gav.... wrote:
> 
>> -----Original Message-----
>> From: David Crossley [mailto:crossley@apache.org]
>> Sent: Friday, 13 April 2007 12:30 PM
>> To: dev@forrest.apache.org
>> Subject: Re: RC1 fails when plugins provide Java source
>>
>> David Crossley wrote:
>>> David Crossley wrote:
>>>> Brian M Dube wrote:
>>>>> The same steps produce the same error on Linux. However, it appears
>> the
>>>>> scope is not limited to the dispatcher. Any plugin that provides
>> Java
>>>>> source will fail. Plugins in trunk are built in $FOO_PLUGIN/build,
>> where
>>>>> the compiled code will end up. This is not the case with RC1. With
>> RC1,
>>>>> the plugins end up in $FORREST_HOME/build/plugins in source form.
>> They
>>>>> are never built.
>>>> Good detective work Brian. Thanks.
>>>>
>>>> Perhaps the Ant target "deploy" target, that makes
>>>> the plugin available for download, does not pack
>>>> the built jar into the zip file.
>>>>
>>>> Thanks again for your valuable input.
>>> Yep this is the problem. I am still investigating
>>> it in head of trunk plugins/build.xml
>> Okay, fixed now in r528349. The dispatcher plugin has
>> been deployed again. Doing basic tests are working now
>> for me.
>>
>> -David
>>
> 
> Yep, Dispatcher does a forrest run and forrest ok for me too in trunk.
> I still get my ant test fail however. I tried to ant test the glossary
> plugin in trunk and that fails too, missing a todo.xml file.


PASSED with RC1: build test (includes dispatcher)

I'm getting a failing ant test too, but that appears to be a problem 
with the test script, not with the plugin itself (since site tests work).

Will continue testing with some of my more esoteric dev sites now.

Ross




Mime
View raw message