forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: plugins 'test' target
Date Fri, 13 Apr 2007 08:40:30 GMT
David Crossley wrote:
> Gav.... wrote:
>> From: Gav....
>>> Same with me, dispatcher broken.
>>>
>>> I did an 'ant test' on the dispatcher plugin in trunk and the
>>> dispatcher-glossary.xml fails validation due to not well formed markup.
>>> Its
>>> been fine
>>> all this time but now fails, don't know when that started to happen.
>>> The dispatcher plugin itself does download and unzip into the build
>>> directory fine in RC1.
>> Dispatcher then relies on the Glossary Plugin for the dispatcher-glossary,
>> but then so does site-author for the glossary.xml.
>>
>> I guess we need to deploy the Glossary Plugin.
> 
> My comments in the other branch of this thread
> about using Forrest's own Ant are still relevant.
> 
> However, i now see the error that you talk about.
> 
> The reason that it did work for me was that i
> had done 'forrest' in the whiteboard/plugins/o.a.f...dispatcher/
> directory before doing 'ant test'. This meant that
> the glossary plugin was already locally deloyed.
> 
> For some reason our plugin 'test' Ant target only
> does a local deploy of the actual plugin that it is
> tesing and not the other plugins that are required
> by this plugin.

Lets keep that as an issue for 0.9, it will not affect the distribution 
since plugin developers will either be committers (using svn head) or 
will have to provide contributions as a patch for review.

Ross

Mime
View raw message