forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: Plugin resolutoin (was Re: [jira] Commented: (FOR-742) trouble accessing unversioned plugin for a released version of Forrest, e.g. projectInfo)
Date Thu, 05 Apr 2007 20:07:08 GMT
David Crossley wrote:
> Ross Gardler wrote:
>> David Crossley wrote:
>>> Ross Gardler wrote:
>>>> Ross Gardler (JIRA) wrote:
>>>>> Ross Gardler commented on FOR-742:
>>>>> ----------------------------------
>>>>>
>>>>> I've deployed the plugins by manually copying the relevant versioned

>>>>> plugins to as the unversioned plugin. 
>>>> I added these by ssh to people.apache.org then doing copying the files 
>>>> in /www/forrest.apache.org/plugins/* followed by relevant svn add.
>>>>
..

>>> However there are other issues ...
>>>
>>> -----------
>>> The plugins have been deployed haphazardly over the time
>>> since the 0.7 release. I was hoping that someone would
>>> review and deploy each. Then we would follow up with copying
>>> them to the unversioned space.
>> This cannot be done without alot of work, and I don't think it is 
>> necessary. We would have to find the point in SVN that the plugin became 
>> a 0.8 plugin, roll back to that time and deploy.
> 
> That is not what i meant, sorry.
> 
> Some of the plugins have been deployed many times
> and so are reasonably up-to-date. Other plugins
> have been worked on in trunk since being deployed.
> The latter changes are not reflected in the currently
> deployed plugin.
> 
> It just takes someone to quickly look at each plugin's
> site, be happy, then deploy both the plugin and its website.

Ah, deploy. OK. Leave it to me.

>>> -----------
>>> I see that you don't have your 'umask' set, so now the files
>>> that you copied have the wrong group permissions and so the
>>> other committers cannot update.
>>> http://www.qpache.org/dev/new-committers-guide.html#shell
>> Really? I've set that in the past. Still I'ce done it again, thanks for 
>> the heads up. I've also sorted out the SVN status.
> 
> However there is still the group permissions problem.
> Please do:
> ssh people.apache.org
> cd /www/forrest.apache.org/plugins
> chgrp -R forrest *

Really? Then my umask setting still doesn't work. Strange.

I've done the chgrp and checked my umask setting again. Perhaps I forgot 
to logout and back in again when I set it last and "fixed" the SVN stuff.

Thanks (once again) for following in my tracks.

Ross


Mime
View raw message