forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject javac version (Was: [apache-forrest-0.8] problem with org.apache.forrest.plugin.output.inputModule)
Date Thu, 26 Apr 2007 02:50:45 GMT
Ron Blaschke wrote:
> Thorsten Scherler wrote:
> > Ron Blaschke wrote:
> >>
> >> I think this is a problem with the plugin.  If you look at the
> >> 0.8/org.apache.forrest.plugin.output.inputModule.zip there's a file
> >> lib/org.apache.forrest.plugin.output.inputModule.jar.  It contains the
> >> ModuleGenerator class.  This class has version 49.0, which is Java 5.
> >>
> >> My pod-input plugins seems to have the same problem.
> >>
> >> After a quick look into plugins/build.xml I think the javac task call
> >> should contain target="1.4" to tell the compiler to always generate Java
> >> 1.4 code.  Otherwise the compiler targets the default version, which is
> >> the own version for recent Sun JDKs.
> >>
> > 
> > Hmm, I think I used 1.5 to compile the inputModule plugin and Ron is
> > right. Ron can you, please, attach a patch to our issue tracker for the
> > build.xml? TIA.
> 
> Will do.

A committer needed to deploy the plugin again anyway,
so i just made the fix.

We had a build.compiler.vm property, but it was not
being used. It is now. We also now use it in main/build.xml
We got away with it for the release because one of
the steps for the Release Manager was to ensure their
system java version. This explicit way is better.

Thanks Ron.

> > I can compile the plugin with 1.4 and this problems will go away, but
> > not for 0.8, or?
> 
> I guess it should work when replaced at
> http://forrest.apache.org/plugins/0.8/ .

I deployed the plugin again. Because it still declares
0.8 as its minimum version, it deploys to the 0.8 directory.

>  If not, it may be necessary to
> remove the plugin from %FORREST_HOME%\build\plugins first.

Lets see. I will reply to the user list too.

-David

Mime
View raw message