forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: [headsup] problem with preparing rc1 - help please.
Date Tue, 10 Apr 2007 13:49:55 GMT
Gav.... wrote:
> David Crossley wrote:
> >
> > By the way, when i return to using the trunk that built
> > the release, then it works properly using the left-over
> > build from running the "release-dist".

I meant going back to my /svn/asf/forrest-trunk-release
and doing
cd site-author
forrest run
... this uses build/xml-forrest.jar and all is well.

I notice that there is a different size with the jar
that gets packed for the release ...

[forrest-trunk-release]$ ls -l build/xml-forrest.jar build/dist/shbat/build/xml-forrest.jar

67164 Apr 10 22:34 build/dist/shbat/build/xml-forrest.jar
66577 Apr 10 22:33 build/xml-forrest.jar

> > I reckon I did this different from you, rather than use
> > D:\Apache2\forrest\build\dist\shbat in place I copied
> > the shbat dir to the same location as where my above
> > release-dist files were unpacked to. (After deleting
> > originals) .
> > 
> > I get the same failed result as above.
> > 
> > I'll try doing it in place now and see what happens there.
> 
> Maybe I'm still doing something different to you.
> 
> ---------------
> D:\Apache2\forrest\build\dist\shbat>cd site-author
> 
> D:\Apache2\forrest\build\dist\shbat\site-author>forrest run
> 
> Apache Forrest.  Run 'forrest -projecthelp' to list options
> 
> 
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/tools/ant/Main
> ---------------

Following what you did, i get:
---------------
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tools/ant/launch/Launcher
---------------

Thanks for confirming that it is not something peculiar
to my system.

Need to review the "release-dist" target.

-David

Mime
View raw message