forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: [headsup] problem with preparing rc1 - help please.
Date Tue, 10 Apr 2007 11:52:11 GMT
David Crossley wrote:
> When i do the quick test of the release candidate package,
> it won't run straight away as advertised at ./index.html
> 
> mkdir /local/08-test-release-rc1 and cd there
> set FORREST_HOME and PATH
> 
> cd site-author
> forrest run
> ---------------
> Apache Forrest.  Run 'forrest -projecthelp' to list options
> 
> Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tools/ant/launch/Launcher
> ---------------
> 
> I also tried to 'cd main; build' but same error
> at the beginning of the process.
> 
> With an up-to-date trunk, try the 'release-dist' target.
> Unpack it and see how you go.
> 
> NOTE: Please do not use that for testing and voting.
> It must be using the final package that i provide
> in the next step.

By the way, when i return to using the trunk that built
the release, then it works properly using the left-over
build from running the "release-dist".

-David

Mime
View raw message