forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Plugin resolutoin (was Re: [jira] Commented: (FOR-742) trouble accessing unversioned plugin for a released version of Forrest, e.g. projectInfo)
Date Thu, 05 Apr 2007 16:59:35 GMT
Ross Gardler wrote:
> David Crossley wrote:
> >Ross Gardler wrote:
> >>Ross Gardler (JIRA) wrote:
> >>>Ross Gardler commented on FOR-742:
> >>>----------------------------------
> >>>
> >>>I've deployed the plugins by manually copying the relevant versioned 
> >>>plugins to as the unversioned plugin. 
> >>I added these by ssh to people.apache.org then doing copying the files 
> >>in /www/forrest.apache.org/plugins/* followed by relevant svn add.
> >>
> >>Am I correct in thinking these changes will make it to the live server 
> >>on the next automated update?
> >
> >Yes they would be picked up on the next rsync.
> >http://www.apache.org/dev/project-site.html
> >
> >I have a local SVN working copy of forrest/site/ so i do
> >such things locally. I didn't think to do it via ssh.
> >That should work.
> >
> >You should have done an 'svn copy' rather than manual copy
> >and then 'svn add'. Also i notice that you haven't done 'svn commit'.
> 
> Yes, I should have done copy, not sure why I didn't. As for the commit, 
> I tried to, but it wouldn't let me. I assumed that I didn't have the 
> permissions because it was going to commit to the public server.

I just did a test. Me too.

> I also should have done it in 
> http://svn.apache.org/repos/asf/forrest/site/plugins (as you suggest) as 
> this is a read only repo.
>
> I was going from memory. Unfortunately it is faulty, I thought that in 
> the past I have done things things here to speed things up. In fact, 
> what needs to be done is you do it in the above then do an SVN up from 
> people.apache.org. this forces an immediate website update. Serves me 
> right for doing it from memory.

I have a cronjob that does the 'svn up' every hour at 07 past.
Then the ASF wide rysnc kicks in at 11 past.
I need to document that somewhere:
http://forrest.apache.org/procedures/How_to_publish_docs.html

> I've cleared up this mess now.
>
> >However there are other issues ...
> >
> >-----------
> >The plugins have been deployed haphazardly over the time
> >since the 0.7 release. I was hoping that someone would
> >review and deploy each. Then we would follow up with copying
> >them to the unversioned space.
> 
> This cannot be done without alot of work, and I don't think it is 
> necessary. We would have to find the point in SVN that the plugin became 
> a 0.8 plugin, roll back to that time and deploy.

That is not what i meant, sorry.

Some of the plugins have been deployed many times
and so are reasonably up-to-date. Other plugins
have been worked on in trunk since being deployed.
The latter changes are not reflected in the currently
deployed plugin.

It just takes someone to quickly look at each plugin's
site, be happy, then deploy both the plugin and its website.

 [ snip ]

Thanks for the excellent explanation. Let us hope that
we can make it all easier. If not then we need to refer
to this email thread as some documentation for next time.

> >-----------
> >I see that you don't have your 'umask' set, so now the files
> >that you copied have the wrong group permissions and so the
> >other committers cannot update.
> >http://www.qpache.org/dev/new-committers-guide.html#shell
> 
> Really? I've set that in the past. Still I'ce done it again, thanks for 
> the heads up. I've also sorted out the SVN status.

However there is still the group permissions problem.
Please do:
ssh people.apache.org
cd /www/forrest.apache.org/plugins
chgrp -R forrest *

-David

Mime
View raw message