forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Re: plugins 'test' target
Date Fri, 13 Apr 2007 23:38:38 GMT
On Fri, 2007-04-13 at 12:00 +0100, Ross Gardler wrote:
> Gav.... wrote:
> > Hmm, I just did a 'forrest' and it failed too due to validation 
> > errors :-
> > 
> > ...
> > validate-xdocs:
> > D:\Apache2\forrest\whiteboard\plugins\org.apache.forrest.plugin.internal.dis
> > patc
> > her\src\documentation\content\xdocs\dispatcher-glossary.xml:70:2: The
> > content of
> >  elements must consist of well-formed character data or markup.
> > 
> > BUILD FAILED
> > D:\Apache2\forrest\main\targets\validate.xml:136: Could not validate
> > document D:
> > \Apache2\forrest\whiteboard\plugins\org.apache.forrest.plugin.internal.dispa
> > tche
> > r\src\documentation\content\xdocs\dispatcher-glossary.xml
> > 
> > Total time: 12 seconds
> > ...
> > 
> > This is in upto date trunk.
> 
> I had that problem at some point. Then it "magically" disappeared.
> 
> Try doing a clean build.

David reported some similar issue and I myself had it a couple of days
back (when I deployed the dispatcher).

Like David after a forrest it went away. 

It seems that the dtd is sometimes not resolved correctly.
<!DOCTYPE glossary PUBLIC "-//Apache Forrest//DTD Glossary V1.0//EN"
"glossary-v10.dtd">

Could be a problem with the catalog resolving.

salu2
-- 
Thorsten Scherler                                 thorsten.at.apache.org
Open Source Java                      consulting, training and solutions


Mime
View raw message