forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav...." <brightoncomput...@brightontown.com.au>
Subject RE: [headsup] problem with preparing rc1 - help please.
Date Tue, 10 Apr 2007 13:18:27 GMT


> -----Original Message-----
> From: Gav.... [mailto:brightoncomputers@brightontown.com.au]
> Sent: Tuesday, 10 April 2007 9:14 PM
> To: dev@forrest.apache.org
> Subject: RE: [headsup] problem with preparing rc1 - help please.
> 
> 
> 
> > -----Original Message-----
> > From: David Crossley [mailto:crossley@apache.org]
> > Sent: Tuesday, 10 April 2007 7:52 PM
> > To: dev@forrest.apache.org
> > Subject: Re: [headsup] problem with preparing rc1 - help please.
> >
> > David Crossley wrote:
> > > When i do the quick test of the release candidate package,
> > > it won't run straight away as advertised at ./index.html
> > >
> > > mkdir /local/08-test-release-rc1 and cd there
> > > set FORREST_HOME and PATH
> > >
> > > cd site-author
> > > forrest run
> > > ---------------
> > > Apache Forrest.  Run 'forrest -projecthelp' to list options
> > >
> > > Exception in thread "main" java.lang.NoClassDefFoundError:
> > org/apache/tools/ant/launch/Launcher
> > > ---------------
> > >
> > > I also tried to 'cd main; build' but same error
> > > at the beginning of the process.
> > >
> > > With an up-to-date trunk, try the 'release-dist' target.
> > > Unpack it and see how you go.
> 
> I get similar to you :-
> 
> --------------
> D:\Apache2\apache-forrest-0.8\site-author>forrest run
> 
> Apache Forrest.  Run 'forrest -projecthelp' to list options
> 
> 
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/tools/ant/Main
> --------------
> 
> This is with me still on Java 5 (1.5-b08) and Windows.
> 
> 
> 
> 
> > >
> > > NOTE: Please do not use that for testing and voting.
> > > It must be using the final package that i provide
> > > in the next step.
> >
> > By the way, when i return to using the trunk that built
> > the release, then it works properly using the left-over
> > build from running the "release-dist".
> 
> I reckon I did this different from you, rather than use
> D:\Apache2\forrest\build\dist\shbat in place I copied
> the shbat dir to the same location as where my above
> release-dist files were unpacked to. (After deleting
> originals) .
> 
> I get the same failed result as above.
> 
> I'll try doing it in place now and see what happens there.

Maybe I'm still doing something different to you.

---------------
D:\Apache2\forrest\build\dist\shbat>cd site-author

D:\Apache2\forrest\build\dist\shbat\site-author>forrest run

Apache Forrest.  Run 'forrest -projecthelp' to list options


Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/tools/ant/Main
---------------

Gav...

> 
> HTH
> 
> Gav...
> 
> >
> > -David
> >
> >
> > --
> > No virus found in this incoming message.
> > Checked by AVG Free Edition.
> > Version: 7.5.446 / Virus Database: 268.18.26/748 - Release Date:
> 4/5/2007
> > 3:33 PM
> 
> 
> --
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.5.446 / Virus Database: 268.18.26/748 - Release Date: 4/5/2007
> 3:33 PM


Mime
View raw message