forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav...." <brightoncomput...@brightontown.com.au>
Subject RE: Site Builds Failing?
Date Tue, 20 Mar 2007 12:04:02 GMT


> -----Original Message-----
> From: Ross Gardler [mailto:rgardler@apache.org]
> Sent: Tuesday, 20 March 2007 8:29 PM
> To: dev@forrest.apache.org
> Subject: Re: Site Builds Failing?
> 
> Gav.... wrote:
> > I have not tried this on site-author yet but I have tried to build and
> > deploy 3 other sites that uses 0.8-dev.
> >
> > On ALL of them now I get build failed.
> >
> > X [0]   index.pdf     BROKEN: master-reference
> >  'book' for fo:page-sequence matches no simple-page-master or
> > page-sequence-master
> >
> >
> > This happens on all PDF files.
> >
> > I'll have a look but if anyone knows already ...
> 
> It is almost certainly a problem local to your system since the
> forrestbot is not failing.
> 
> Ross

It would seem that way you would think.

I have done from forrest_home 

'svn revert . -R'
'svn up'
cd/main
forrest clean
build

Then tried building my sites again, no difference.

What is the best practice people use when they have to bring their site
directories and builds upto date with trunk?

If they were built from 'forrest seed' or 'forrest seed-sample' and then
all the content .xml files were added, site.xml, tabs.xml etc all altered
etc etc, but then trunk has changed along the way, these sites may now
not be compatible when built again.

This is just a guess at what has happened to my sites.

Is it safe to copy the src/documentation/** directories elsewhere, seed a
new
site and then copy ssrc/documentation/** back again, would that work?

(Suppose I better try it, just wondering what others did)

Gav...

> 
> 
> --
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.5.446 / Virus Database: 268.18.11/722 - Release Date: 3/14/2007
> 3:38 PM


Mime
View raw message