forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: Problems running 0.7 site-author
Date Wed, 14 Feb 2007 09:30:36 GMT
Ferdinand Soethe wrote:
> I'm just preparing new instructions for getting started with Forrest 0.7
> for a presentation and I'm running into a strange kind of problem:
> 
> Here is what I did
> 
> - Download Forrest 0.7
> - Set Environment and Path for Windows XP
> - cd to site-author
> - execute "forrest run"
> - try localhost:8888 in my browser
> 
> What I get is this:
> 
>> Internal Server Error
>>
>> Message: null
>>
>> Description: No details available.
>>
>> Sender: org.apache.cocoon.servlet.CocoonServlet
>>
>> Source: Cocoon Servlet
>>
>> Request URI
>>
>> cause
>>
>> Could not find component for role: [org.apache.cocoon.components.modules.input.InputModule/lm]
(Key='org.apache.cocoon.components.modules.input.InputModule/lm')
>>
>> request-uri
>>
>> /
>>
>> Apache Cocoon 2.2.0-dev
> 
> Any ideas why this is happening in a tested and released version?
> Quick fixes?

You are using a plugin that has been upgrade to use the locationmap that 
is only available in 0.8.

Unfortunately, the version management of plugins in 0.7 had a bug that 
means when retrieving an unversioned plugin it will always retrieve the 
most recent rather than the most recent for the version of Forrest being 
run.

You need to add a version number to the project-info plugin (I'm pretty 
sure that is the one with the problem). Search the user list for this issue.

Ross

Mime
View raw message