forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Re: Cli and forms
Date Sat, 13 Jan 2007 20:10:56 GMT
On Sat, 2007-01-13 at 14:04 +0100, Thorsten Scherler wrote:
> Hi all,
> 
> I nearly fixed all issues with the solr plugin that have been CLI
> related. Only one is left.
> 
> <link message="Server returned HTTP response code: 400 for URL:
> http://localhost:8983/solr/select?user-agent=Apache Cocoon
> 2.2.0-dev&accept=*/*" uri="/solr-search.html">
>     <referrer uri="linkmap.html"/>
> ...
>   </link>
> 
> The problem is, that the crawler is requesting the action url 
> from the solr search form (stored on each page), but use too less parameter:
> http://localhost:8983/solr/select?user-agent=Apache Cocoon 2.2.0-dev&accept=*/*
> 
> I need to have a closer look into "lucene-search.html" but maybe somebody has an idea,

> how to pass some default parameter to the CLI or how to workaround above problem.

Well actually if you activate lucene then it will produce
lucene-search.html. Meaning the action url will be crawled.

Lucene uses a generator that is requesting null as search against the
index. This will return the result null but not an error.

I guess best way to write a solr generator acting the same way as the
one from lucene.

salu2

> 
> TIA for any thoughts
> 
> salu2
-- 
thorsten

"Together we stand, divided we fall!" 
Hey you (Pink Floyd)



Mime
View raw message