forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <>
Subject Re: Building Forrest 2
Date Thu, 23 Nov 2006 01:12:35 GMT
David Crossley wrote:
> Ross Gardler wrote:
>> David Crossley wrote:
>>> Ross Gardler wrote:
>>>> David Crossley wrote:
>>>>> Ross Gardler wrote:
>>>>>> There are some example content objects in
>>>>>> src/examples for you to try out, for example:
>>>>>> ant -Dcontent.object.dir=[FORREST2_HOME]/src/examples/helloWorld

>>>>>> -Dcontent.object.start.uri=helloWorld.html run
>>>>>> I hope you have more success with this, of course, let me know if
>>>>>> don't
>>>>> Doesn't work for me: "Mac OS X" Java5:
>>>>> svn up
>>>>> cd /svn/asf/forrest/whiteboard/forrest2/core
>>>>> ant clean; ant compile-core
>>>>> ant -Dcontent.object.dir=src/examples/helloWorld 
>>>>> -Dcontent.object.start.uri=helloWorld.html run
>>>>> ...
>>>>> ...
>>>>>    [java] 0    [main] INFO  org.apache.forrest.core.Controller (?:?)
>>>>>    Using Spring Context definition in src/forrestContext.xml
>>>>>    [java] 
>>>>>    org.springframework.beans.factory.BeanDefinitionStoreException: 
>>>>>    IOException parsing XML document from file 
>>>>>    [/svn/asf/forrest/whiteboard/forrest2/core/src/examples/helloWorld/svn/asf/forrest/whiteboard/forrest2/core/src/examples/helloWorld/src/forrestContext.xml];
nested exception is svn/asf/forrest/whiteboard/forrest2/core/src/examples/helloWorld/src/forrestContext.xml
(No such file or directory)
>>>>>    [java] Caused by: 
>>>>>    svn/asf/forrest/whiteboard/forrest2/core/src/examples/helloWorld/src/forrestContext.xml
(No such file or directory)
>>>>>    [java]     at Method)
>>>>> ...
>>>>> ---------------
>>>>> Seems to be mangling the pathname somehow. Also tried with
>>>>> full pathname for content.object.dir with same result.
>>>> That forrestContext.xml file should exist in the location indicated 
>>>> (assuming svn/asf/forrest/whiteboard/forrest2/core is the path to your 
>>>> forrest2 code). See [1]
>>>> Can you please verify that is the case.
>>> I checked all that before sending the errors.
>>> As i said, please note the mangled paths and the missing leading slash
>>> on the Exception messages.
>> Sorry for being dense, I only looked at the "Caused by:" part of the 
>> report, not the original IO Exception. Interestingly they give two 
>> different paths.
> The first path is mangled, the second path is missing the leading slash.
> Perhaps as a result of the first mess.
>> Anyway, I note your ANT command is:
>> ant -Dcontent.object.dir=src/examples/helloWorld 
>> -Dcontent.object.start.uri=helloWorld.html run
>> This works OK for me (Cygwin on Windows XP), so I guess this is a MacOS 
>> thing.
> My unsaid question is: Is there specific code anywhere in forrest2
> that builds that pathname? It might have some "file:" handling which
> is a typical thing that causes pathname errors between UNIX/Windows.

I really am trying to do too many things tonight (the Ashes have start 
as well, so that's me out of the real world for 5 days)

It's in

The CLI calls the default constructor which calls 
this("src/locationmap.xml", "src/forrestContext.xml");

The file resolution is in the parameterised constructor and consists of 
two parts:

final File file = new File(contextPath);


this.context = new FileSystemXmlApplicationContext(file		 

(contextPath in the first line is the "src/forrestContext.xml")

The problem is that getAbsolutePath() should be getPath().

I've made the change, please test.


View raw message