forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Børre Gaup <boe...@skolelinux.no>
Subject Re: HTML source files broken
Date Mon, 06 Nov 2006 22:54:54 GMT
On Mon, November 6. b. 2006 23:09, David Crossley wrote:
> David Crossley wrote:
> > B??rre Gaup wrote:
> > > The reason for this error was the we had hyphens (-) in the filename.
> > > When we replaced the hyphens with underscores, everything worked like a
> > > charm again.
> >
> > That is strange. I have a site that uses Dispatcher (pelt) and
> > an html source which has hyphens in the filename. I get no errors.
>
> Just in case we missed this observation.
>
> I use a slight modification of the "pelt" theme
> and have no such problems.
>
> What is the difference between your theme and the default.
> Perhaps an additional contract.
>
> -David

Sorry to have made such a fuzz.

The error was in our own sitemap. The problematic part was the following:

   <map:pipelines>
        <map:pipeline>
	....
	(some line cut away)
	.....
           <map:match pattern="**corpus-*.xml">
                <map:generate src="{properties:content.xdocs}
{1}corpus-content.xml" />
                <map:transform 
src="{properties:resources.stylesheets}/corpus-lang-overview2document.xsl">
                    <map:parameter name="overviewlang" value="{2}" />
                </map:transform>
                <map:transform type="i18n">
                    <map:parameter name="locale" value="en" />
                </map:transform>
                <map:serialize type="xml" />
            </map:match>

	....
	(some line cut away)
	.....

        </map:pipeline>
</map:pipelines>

which inadvertently caught not only the intended "corpus-" files, but also 
some unintended ones, as you all know by now (blush) ...

Once again, sorry to have made such a fuzz out of this, and thanks for the 
care and concern you have shown.

Regards,
-- 
Børre Gaup

Mime
View raw message