forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FOR-765) forrest war gets NoSuchMethodError for some core transformer
Date Wed, 08 Nov 2006 12:46:53 GMT
    [ http://issues.apache.org/jira/browse/FOR-765?page=comments#action_12448124 ] 
            
Gavin commented on FOR-765:
---------------------------

Has anyone else tried this lately ?

I just now tried it using Tomcat 6.0, 

I first packaged a war file using 'forrest seed-sample war' - no errors , all went fine.

I then loaded it into Tomcat, loaded fine, viewed it in 

http://localhost:8080/my-project/index.html;jsessionid=56E871C1729BD756E857C7897BBB067B

and it all works fine. Maybe its because I'm using Tomcat and not Jetty, Java 5 and not Java
4 ??

Hmm, maybe these comments aren't much use, usual 'works ok for me..' scenario, but I went
to look at the problem and I don't get one , so where to from here, 

more testers please !! and quote your Platform, Tomcat version, Java Version.

Hope these comments narrow it down a bit.

Let me know more specific testing requirements if you want me to do more testing.


> forrest war gets NoSuchMethodError for some core transformer
> ------------------------------------------------------------
>
>                 Key: FOR-765
>                 URL: http://issues.apache.org/jira/browse/FOR-765
>             Project: Forrest
>          Issue Type: Bug
>          Components: Launch servlet WAR
>    Affects Versions: 0.8-dev
>            Reporter: David Crossley
>             Fix For: 0.8-dev
>
>         Attachments: jetty-out.log
>
>
> Until recently we could run forrest as a WAR. With today's SVN r356945 it gets past the
Cocoon startup phase, then on the first client request it suffers some error which causes
a NoSuchMethodError. See attached log ... no other clues. This happens for any site, e.g.
'forrest seed-sample war'. All is okay for 'forrest seed-sample run'.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message