forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cyriaque Dupoirieux <Cyriaque.Dupoiri...@pcotech.fr>
Subject Re: Can not enable own theme
Date Mon, 11 Sep 2006 07:18:22 GMT
le 11/09/2006 01:30 Gav.... a écrit :
> So it seems I needed to enable :-
>
> project.content-dir=src/documentation
> project.xdocs-dir=${project.content-dir}/content/xdocs
> project.resources-dir=${project.content-dir}/resources
>
> and now it works, must have missed this change, either way
> should I update Dispatcher Quickstart to refelect this?
>   
These values are the default ones. I don't think it's necessary to set 
them again in your forrest.properties.
Maybe your problem is elsewhere ?

Salutations,
Cyriaque,
> Gav...
>
>   
>> -----Original Message-----
>> From: Gav.... [mailto:brightoncomputers@brightontown.com.au]
>> Sent: Sunday, 10 September 2006 9:31 PM
>> To: dev@forrest.apache.org
>> Subject: RE: Can not enable own theme
>>
>>
>>
>>     
>>> -----Original Message-----
>>> From: Gav.... [mailto:brightoncomputers@brightontown.com.au]
>>> Sent: Sunday, 10 September 2006 9:00 PM
>>> To: dev@forrest.apache.org
>>> Subject: RE: Can not enable own theme
>>>
>>>
>>>
>>>       
>>>> -----Original Message-----
>>>> From: Gav.... [mailto:brightoncomputers@brightontown.com.au]
>>>> Sent: Sunday, 10 September 2006 3:42 PM
>>>> To: dev@forrest.apache.org
>>>> Subject: Can not enable own theme
>>>>
>>>> Not sure if it just me not kept abreast of changes the last couple of
>>>> weeks
>>>> but ...
>>>>
>>>> I have after doing a 'forrest seed-sample'
>>>>
>>>> 1. created a new theme,
>>>> 2. added it to /themes/newTheme/ directory of site,
>>>> 3. added newTheme.fv to main /themes/ directory,
>>>> 4. enabled 'project.theme=newTheme' in forrest.properties,
>>>> 5. changed <property name="dispatcher.theme" value="newTheme"/> in
>>>> forrest.properties.xml (worth a try after everything else failed)
>>>> 6. In case FOR-866 was relevant , deployed locally the required
>>>>         
>> plugins.
>>     
>>>> All to no avail.
>>>>
>>>> 'forrest run' and 'forrest' both seem to be ignoring themes and using
>>>>         
>> a
>>     
>>>> pelt
>>>> skin instead.
>>>>         
>>> Wrong on that, Pelt Theme is being used, so my own theme is being
>>>       
>> ignored.
>>     
>>> Gav...
>>>       
>> Still not working, If I remove 'Pelt Theme' then the Common Theme gets
>> used,
>> If I remove the Common Theme also, then another 'Pelt Theme' comes into
>> play
>> >From somewhere else.
>>
>> I have been looking in the internal.dispatcher plugin, and am confused by
>> Various uses of 'theme' 'themer' and 'themes' when used with properties:
>> And dispatcher.* - should there be one consistent version here or are
>> All these variations intentional?
>>
>> Ta
>>
>> Gav...
>>
>>     
>>>> Will keep looking, but can anyone see what I have missed / has been
>>>> changed
>>>> ?
>>>>
>>>> Thanks
>>>>
>>>> Gav...
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> No virus found in this incoming message.
>>>> Checked by AVG Free Edition.
>>>> Version: 7.1.405 / Virus Database: 268.12.2/442 - Release Date:
>>>>         
>> 9/8/2006
>>     
>>>
>>>
>>>
>>> --
>>> No virus found in this incoming message.
>>> Checked by AVG Free Edition.
>>> Version: 7.1.405 / Virus Database: 268.12.2/442 - Release Date: 9/8/2006
>>>       
>>
>>
>>
>> --
>> No virus found in this incoming message.
>> Checked by AVG Free Edition.
>> Version: 7.1.405 / Virus Database: 268.12.2/442 - Release Date: 9/8/2006
>>     
>
>
>
>
>   

Mime
View raw message