forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav...." <brightoncomput...@brightontown.com.au>
Subject FOR-635 Revisted
Date Fri, 22 Sep 2006 13:31:28 GMT
Hi All, 

Taking yet another look at FOR-635, lets see if we can get this thing
licked.!

Some observations from a 'forrest run' - ( I could have sworn more images
than just one in linking.pdf last time we looked at this, but anyway)

Forrest Run 



1. Actual Location is : src/documentation/resources/images/
   linking.fo says    : <fo:external-graphic src="/images/icon-a.png"/>
   linking.html says  : <img alt="Icon" src="/images/icon-a.png">

   http://localhost:8888/images/icon-a.png - Image appears fine.

   Image does NOT appear in linking.pdf

2. Actual Location is : src/documentation/resources/images/sub-dir/
   linking.fo says    : <fo:external-graphic
src="/images/sub-dir/icon-c.png"/>
   linking.html says  : <img alt="Icon" src="/images/sub-dir/icon-c.png">

   http://localhost:8888/images/sub-dir/icon-c.png - Image appears fine.

   Image does NOT appear in linking.pdf

3. Actual Location is : src/documentation/content/xdocs/images/ 
   linking.fo says    : <fo:external-graphic src="/images/icon-e.png"/>
   linking.html says  : <img alt="Icon" src="/images/icon-e.png">

   http://localhost:8888/images/icon-e.png - Image appears fine.

   Image does NOT appear in linking.pdf

4. Actual Location is : src/documentation/resources/images/
   linking.fo says    : <fo:external-graphic
src="D:\web\FOR-635/src/documentation/resources/images///icon-a.png"/>
   linking.html says  : <img alt="Icon" src="images/icon-a.png">

   http://localhost:8888/images/icon-a.png - Image appears fine

   Image DOES appear in linking.pdf

5. Actual Location is : src/documentation/resources/images/
   linking.fo says    : <fo:external-graphic src=""/>
   linking.html says  : <img alt="Icon" src="../images/icon-a.png">

   http://localhost:8888/../images/icon-a.png - Image appears fine.

   Image does NOT appear in linking.pdf

6. Actual Location is : src/documentation/resources/images/ 
   linking.fo says    : <fo:external-graphic src=""/>
   linking.html says  : <img alt="Icon" src="../../images/icon-b.png">

   http://localhost:8888/../../images/icon-b.png - Image appears fine.

   Image does NOT appear in linking.pdf

7. Actual Location is : src/documentation/resources/images/
   linking.fo says    : <fo:external-graphic src="/images/ellipse-2.png"/>
   linking.html says  : <img alt="Icon" src="/images/ellipse-2.png">

   http://localhost:8888/images/ellipse-2.png - Image appears fine.

   Image does NOT appear in linking.pdf


1. Actual Location is : src/documentation/content/xdocs/samples/
   linking.fo says    : <fo:external-graphic src=""/>
   linking.html says  : <img alt="Icon" src="ellipse.png">

   http://localhost:8888/samples/ellipse.png - Image appears fine

   Image does NOT appear in linking.pdf

2. Actual Location is : src/documentation/content/xdocs/samples/
   linking.fo says    : <fo:external-graphic src=""/>
   linking.html says  : <img alt="Icon" src="cocoon-pyramid.png">

   http://localhost:8888/samples/cocooon-pyramid.png - Image appears fine.

   Image does NOT appear in linking.pdf

3. Actual Location is : src/documentation/content/xdocs/samples/
   linking.fo says    : <fo:external-graphic src=""/>
   linking.html says  : <img alt="Icon" src="icon-d.png">

   http://localhost:8888/samples/icon-d.png - Image appears fine.

   Image does NOT appear in linking.pdf


Summary: Doing a Forrest Run then and Image number 4 is the ONLY one that
appears in linking.pdf.
         This is the only image that is not referenced with a leading '/'  -
except the 3 SVG images. It is also the only image the linking.fo sees as 
An absolute URL.


Im going to do a run through of the first image first and see if I can spot
anything.

Apologies for being quiet of late, been a bit hectic down here but getting
on Top of things now.

Gav...



Mime
View raw message