forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav...." <brightoncomput...@brightontown.com.au>
Subject RE: Publish site from site-author (was : RE: svn commit:r426852...)
Date Wed, 02 Aug 2006 12:47:10 GMT


> -----Original Message-----
> From: David Crossley [mailto:crossley@apache.org]
> Sent: Wednesday, 2 August 2006 2:15 PM
> To: dev@forrest.apache.org
> Subject: Re: Publish site from site-author (was : RE: svn
> commit:r426852...)
> 
> Gav.... wrote:
> >
> > Well, the normal svn cleanup did not work. I deleted the main/* and
> > site-author/* directories and svn up to get them again.
> >
> > Forrest -f publish.xml build succeeded fine as usual.
> >
> > Forrest -f publish.xml deploy did what it did the first time :-
> >
> > D:\Apache2\forrest\site-author>forrest -f publish.xml deploy
> >
> > Apache Forrest.  Run 'forrest -projecthelp' to list options
> >
> >
> > Buildfile: publish.xml
> >
> > deploy.svn:
> > add: Put files and directories under version control, scheduling
> > them for addition to repository.  They will be added in next commit.
> > usage: add PATH...
> > Valid options:
> >   --targets arg            : pass contents of file ARG as additional
> args
> >   -N [--non-recursive]     : operate on single directory only
> >   -q [--quiet]             : print as little as possible
> >   --config-dir arg         : read user configuration files from
> directory
> > ARG
> >   --force                  : force operation to run
> >   --no-ignore              : disregard default and svn:ignore property
> > ignores
> >   --auto-props             : enable automatic properties
> >   --no-auto-props          : disable automatic properties
> > Result: 1
> >
> > BUILD SUCCESSFUL
> > Total time: 11 minutes 11 seconds
> >
> > ---------------
> >
> > However , no commit log has appeared so yet again this actually did
> nothing.
> 
> That is normal for the first deploy.

Ok thanks.

> Do both steps again:
> 
> forrest -f publish.xml build
> forrest -f publish.xml deploy
> 
> If you still have the line-endings problem then that is
> some different issue.

Not done that yet, need a genuine change to try it.

> 
> Try making a little change to one of the source xdocs, e.g. index.xml
> but no need to commit it.

Done that.

> 
> Then build as normal:
> forrest -f publish.xml build

Done that.

> 
> Then get your forrestbot's site svn up-to-date, You don't
> normally need to do this step:
> svn update work/svn-deploy/forrest-docs

Done that, very big amount of updates and adds happened.

> 
> Then tell us the differences:
> diff build/forrest-docs/index.html work/svn-deploy/forrest-docs/index.html


Erk, 

D:\Apache2\forrest\site-author>svn diff build\forrest-docs\index.html
work\svn-d
eploy\forrest-docs\index.html
svn: 'build\forrest-docs\index.html' is not a working copy

> 
> > > > Thanks for your help so far, cheers.
> > >
> > > If we get you to deploy the site once in while then the project is
> > > getting stronger.
> > >
> > > You are very welcome.
> > >
> > > We are all here to learn and help each other, or?
> >
> > Absolutely, it is frustrating though that I can not get over this hurdle
> > Quickly so I can move on and close some issues.
> 
> Please don't rush, there are probably more "hurdles".

No doubt !

:)

Gav...

> 
> -David
> 
> 
> --
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.394 / Virus Database: 268.10.5/405 - Release Date: 8/1/2006




Mime
View raw message