forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Williams" <william...@gmail.com>
Subject Re: Forrestbot errors on site-author
Date Tue, 18 Jul 2006 03:00:07 GMT
On 7/17/06, David Crossley <crossley@apache.org> wrote:
> Tim Williams wrote:
> > David Crossley wrote:
> > >Ross Gardler wrote:
> > >> Tim Williams wrote:
> > >> >Ross Gardler wrote:
> > >> >>Tim Williams wrote:
> > >> >>>
> > >> >>> Forrestbot build works successfully.  I get to the deploy
step and I
> > >> >>> get the result below.  Any pointers greatly appreciated...
> > >> >>>
> > >> >>> C:\src\apache-forrest-trunk-s\site-author>forrest -f publish.xml
> > >deploy
> > >> >>>
> > >> >>> Apache Forrest.  Run 'forrest -projecthelp' to list options
> > >> >>>
> > >> >>>
> > >> >>> Buildfile: publish.xml
> > >> >>>
> > >> >>> deploy.svn:
> > >> >>> svn: 'M
> > >> >>> pluginDocs\plugins_0_70\org.apache.forrest.plugin.internal.IMSManife
> > >> >>>
> > >>
> > >>>st\repositoryCommand\getSCO\HowTo\repositoryURI\www.burrokeet.org\repositoryData
> > >>
> > >> ...
> > >>
> > >> >I tried these... no luck.  I checked out a completely fresh trunk,
> > >> >build, forrestbot... same message. This is also the same error I was
> > >> >getting last time IIRC.  Any other ideas?
> > >>
> > >> I just did a test deploy using Cygwin on Windows XP.
> > >>
> > >> There were no problems so this would appear to be a local problem on
> > >> your machine. I'm at a loss what since you say you have cleaned
> > >> eveything out.
> > >>
> > >> Note doing a fresh checkout does not necessarily clear your SVN
> > >> workspace since (I think) are at FORREST_HOME/site-author/work.
> > >
> > >Tim, did you follow Ross' suggestion?
> > >
> > >Try removing forrestbot's site-author/work and
> > >perhaps also site-author/build/forrest-docs/ directory.
> > >
> > >Remember that forrestbot does a checkout of the
> > >forrest/site SVN, which also contains all the docs
> > >for each plugin.
> >
> > Yes, I tried the suggestions.  When I did the fresh checkout, it was
> > of all of forrest and I did set FORREST_HOME to point to it. No luck.
> > Any other pointers?
>
> For me there is an svn directory at
> site-author/work/svn-deploy/forrest-docs/pluginDocs/plugins_0_70/org.apache.forrest.plugin.internal.IMSManifest/repositoryCommand/getSCO/HowTo/repositoryURI/www.burrokeet.org/repositoryData/.svn/
>
> Do you have one too?

I do.

> This is a stab in the dark, but try doing
> cd site-author/work/svn-deploy/forrest-docs
> svn cleanup

The command completes and though it took a while, it seems to have had
no effect.

> What does the following produce?
> cd site-author/work/svn-deploy/forrest-docs
> svn info
>
> For me it is:
> URL: https://svn.apache.org/repos/asf/forrest/site

Same here.

I get the same error(see below) as before.  The files in the directory
look fine to me.

Thanks,
--tim

deploy.svn:
svn: 'M     pluginDocs\plugins_0_70\org.apache.forrest.plugin.internal.IMSManife
st\repositoryCommand\getSCO\HowTo\repositoryURI\www.burrokeet.org\repositoryData
' is not a working copy
Result: 1

Mime
View raw message