forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Eggers <its_toas...@yahoo.com>
Subject Forrest failure under Cygwin
Date Thu, 06 Jul 2006 02:31:23 GMT
I recently upgraded Cygwin on a Windows/2000
Professional machine to:

bash-3.1$ uname -a
CYGWIN_NT-5.0 phoenix 1.5.20(0.156/4/2) 2006-07-01
02:22 i686 Cygwin

bash-3.1$ cygpath --version
cygpath (cygwin) 1.42
Path Conversion Utility
Copyright 1998, 1999, 2000, 2001, 2002, 2003, 2004,
2005 Red Hat, Inc.
Compiled on Jul  1 2006

bash-3.1$ bash --version
GNU bash, version 3.1.17(6)-release (i686-pc-cygwin)
Copyright (C) 2005 Free Software Foundation, Inc.

Forrest stopped working and gave the following error.

bash-3.1$ pwd
/cygdrive/c/src/forrest/site-author
bash-3.1$ echo $FORREST_HOME
C:\src\forrest
bash-3.1$ forrest
Apache Forrest.  Run 'forrest -projecthelp' to list
options

Buildfile: C:\src\forrest\main\forrest.build.xml

BUILD FAILED
Target
`c:/src/forrest/lib/endorsed/jakarta-regexp-1.4.jar'
does not exist in this project. 

Total time: 1 second

After investigating, it seems that the loop populating
the CLASSPATH was not being executed.

It appears that the bash shell no longer understands 

C:\src\forrest/lib/endorsed/*.jar

I made the following quick hack to
$FORREST_HOME/bin/forrest:

bash-3.1$ svn diff forrest
Index: forrest
===================================================================
--- forrest	(revision 419404)
+++ forrest	(working copy)
@@ -70,9 +70,11 @@
 if [ "$cygwin" = "true" ] ; then
   S=';'
   FORREST_DOT_HOME=`cygpath -w "$FORREST_HOME"`
+  FORREST_SHELL_HOME=`cygpath -u "$FORREST_HOME"`
 else
   S=':'
   FORREST_DOT_HOME=$FORREST_HOME
+  FOREST_SHELL_HOME=$FORREST_HOME
 fi
 
 # set the ant file to use
@@ -82,7 +84,7 @@
 export CP
 unset CLASSPATH
 
-for i in $FORREST_HOME/lib/endorsed/*.jar; do
+for i in $FORREST_SHELL_HOME/lib/endorsed/*.jar; do
   if [ "$cygwin" = "true" ] ; then
     LIB=`cygpath -w $i`
   else

This seems to fix the problem.

Is someone else interested in verifying this behavior?
 I don't want to open an issue and supply a patch if
this is just an environmental artifact.

Mark
just my two cents . . . .

/mde/

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

Mime
View raw message