forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferdinand Soethe <ferdin...@apache.org>
Subject Re: Broken site-author (was Re: docs restructure (Was: svn commit: r407256)) Urgent!
Date Thu, 18 May 2006 16:25:22 GMT
Thanks Mark,

you may be right about this even though I'm getting a different error
message. But it is really far beyond me to make sense of the
situation.

So if it's not just me having problems compiling docs with the current
version, can we please fix this or roll back (the responsible code
changes, NOT the doc changes, please) rather soon.

And if its just me, can sbdy please compile current docs and post the
link errors report.

Thanks,
Ferdinand






Mark Eggers wrote:

> The only way I've been able to build static sites
> since the upgrade of ant is to turn off validation.

> I'm running on Windows/2000 Professional and jdk
> 1.5.0_06.  I've removed ANT_HOME, all CLASSPATH
> information, and %ANT_HOME%\bin from my path.

> When I do that, I get the following error when running
> at the CMD.exe prompt or under Cygwin.

> validate-xdocs:

> BUILD FAILED
> C:\src\forrest\main\targets\validate.xml:146: Could
> not validate document
> C:\src\sites-src\normal\src\documentation\content\xdocs\samples\linking.xml

> Looking at line 146 at validate.xml, it seems that
> this is where the parser is defined.

> <xmlvalidate 
>   failonerror="${forrest.validate.xdocs.failonerror}" 
>   lenient="no" warn="yes" classpathref="forrest.cp" 
>   classname="org.apache.xerces.parsers.SAXParser">

> This class is in xeresImpl-2.8.0, which is in the
> endorsed subdirectory of lib.

> I noticed that -lib was replaced with -cp in the ant
> scripts when ant was changed.  Did this change get
> reflected in all of the forrest scripts?

> If I've missed something, please let me know.

> Thanks,

> /mde/

> --- Ferdinand Soethe <ferdinand@apache.org> wrote:

>> Seems like somebody beat me to breaking docs.
>> 
>> > Plugin org.apache.forrest.plugin.input.glossary
>> deployed ! Ready to configure
>> > Fetch-plugin Ok, installing !
>> > 
>> > configure-input-plugin:
>> > Mounting input plugin:
>> org.apache.forrest.plugin.input.glossary
>> > Processing
>>
> C:\U_Daten\forrest\head\site-author\build\tmp\input.xmap
>> to C:\U_Date
>> >
>> n\forrest\head\site-author\build\tmp\input.xmap.new
>> > Loading stylesheet
>>
> C:\U_Daten\forrest\head\main\var\pluginMountSnippet.xsl
>> > Moving 1 file to
>> C:\U_Daten\forrest\head\site-author\build\tmp
>> > 
>> > BUILD FAILED
>> >
>>
> C:\U_Daten\forrest\head\main\targets\plugins.xml:390:
>> The following error occurr
>> > ed while executing this line:
>> >
>>
> C:\U_Daten\forrest\head\main\targets\plugins.xml:418:
>> The following error occurr
>> > ed while executing this line:
>> >
>>
> C:\U_Daten\forrest\head\main\targets\plugins.xml:154:
>> The following error occurr
>> > ed while executing this line:
>> >
>>
> C:\U_Daten\forrest\head\main\targets\plugins.xml:239:
>> Failed to copy C:\U_Daten\
>> > forrest\head\site-author\build\tmp\input.xmap.new
>> to C:\U_Daten\forrest\head\sit
>> > e-author\build\tmp\input.xmap due to
>> C:\U_Daten\forrest\head\site-author\build\t
>> > mp\input.xmap (Zugriff verweigert)
>> 
>> Can anybody suggest a way of fixing this?
>> I really need to because I need the list of broken
>> links to fix them.


> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around 
> http://mail.yahoo.com 



--
Ferdinand Soethe


Mime
View raw message