forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: Plugin auto deploy sometimes fails (Re: help - yet another Dispatcher false start)
Date Tue, 23 May 2006 12:58:55 GMT
Cyriaque Dupoirieux wrote:
> le 23/05/2006 10:55 Thorsten Scherler a écrit :
> 
>> Ross Gardler schrieb:
>>
>>> Cyriaque Dupoirieux wrote:
>>>
>>>> le 22/05/2006 04:19 David Crossley a écrit :
>>>
>>>
>>> ...
>>>
>>>
>>>>> The org.apache.forrest.themes.core "plugin" is not
>>>>> described in the whiteboard-plugins.xml file.
>>>>>   
>>>>
>>>>
>>>> Thank you very much David, that's it !
>>>> I wanted to answer, but I was not there :-P .
>>>
>>>
>>> Wow, that was really easy. Sorry I did not have the time to look for 
>>> that. I think this shows the importance of not having dependencies 
>>> between plugins, or at least providing a mechanism for auto resolving 
>>> plugins. Another objective for 0.9 I think,
>>>
>>> Ross
>>>
>>>
>>
>> I have ATM no time at all to read any mail or do any work since I am 
>> still away at a customer. I just read the first mail of this thread, 
>> the one from Cyriaque and this one.
>>
>> Can *somebody* actually update the whiteboard-plugins.xml and solve 
>> the root issue? That would be nice.
> 
> Yes, I would like to do this, but I need to deploy the core plugin and I 
> don't know exactly how ?
> Can someone help ?

There is no need to deploy it to the remote server, although if you want 
to all you do is "ant deploy" (see plugin docs). Note that this will run 
the plugin tests (building local documentation by default), if the tests 
fail, the deploy will fail.

In terms of local-deploy it should just be a case of putting it in 
whiteboard-plugins.xml as Thorsten says.

I'm on a machine that allows me to do SVN commits later today. I'll give 
it a go then.

Ross







Mime
View raw message