forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <>
Subject Plugin auto deploy sometimes fails (Re: help - yet another Dispatcher false start)
Date Sun, 21 May 2006 23:23:02 GMT
Mark Eggers wrote:
> Ross,
> Ah, ha!  That's the problem.  I never specified the
> directory location in the required plugins line.
> You put:
> project.required.plugins.src=${forrest.home}/plugins,${forrest.home}/whiteboard/plugins


> I guess if I add a project.required.plugins.src line
> the location map would grab the appropriate source.  I
> didn't see that line in any of my seeded projects.

No need to specifically add it. If a property is missing from your local file the entry is used, 
i.e. that copied above.

> I added the above line explicitly to a
> file and tried running the
> dispatcher without building the whiteboard plugins.  I
> got a locatiommap error.
> This doesn't seem to happen when using a
> non-dispatcher configuration.  I've not tried this
> with j-random plugins from whiteboard/plugins.

Thanks for doing some testing on this. I've been trying to find the time 
to establish if this is a dispatcher specific problem or a more general 
problem with plugin autodeploy.

I've linked this thread to the issue so we don't lose your valuable 


View raw message