forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian M Dube <brian.d...@gmail.com>
Subject Re: help - yet another Dispatcher false start
Date Fri, 19 May 2006 23:37:53 GMT
Ross Gardler wrote:
> I again tried to work with the dispatcher this evening. However, once 
> again I failed miserably.
> 
> I just don't seem to be able to get things working.
> 
> I started from the getting started document, but that seems to be 
> horribly out of date. It still talks about using specific revisions and 
> applying patches. I'm fairly certain that is no longer necessary - right?

Correct, it is not necessary with HEAD.

> So I tried created a new seeded sight and added the dispatcher plugins 
> to forrest.properties as per the getting started instructions.
 >
> I did "forrest run" then pointed my browser at http://localhost:8888
> 
> No go...
> 
> I get a failure in the LM, it can't find lm:resolve.structurer.index

I get a locationmap failure if I don't deploy locally 
org.apache.forrest.themes.core and 
org.apache.forrest.plugin.internal.dispatcher.

> I verified such an LM match exists.
> 
> What confuses me is that Mark said in another thread that he tested the 
> dispatcher today and it worked just fine. So I must be doing something 
> stupid.
> 
> Can someone please give me a set of commands that will make a fresh 
> dispatcher site build from SVN head. I am desperate to move my 
> dispatcher 2 sites over to dispatcher 3 so I can start building them 
> with SVN head again (currently I'm stuck on a dispatcher 2 checkout).

This works for me:

$ cd $FORREST_HOME
$ svn up
updated to 407927
$ cd main
$ ./build.sh clean
$ ./build.sh
$ cd ../whiteboard/plugins/org.apache.forrest.themes.core
$ $FORREST_HOME/tools/ant/bin/ant local-deploy
$ cd ../org.apache.forrest.plugin.internal.dispatcher
$ $FORREST_HOME/tools/ant/bin/ant local-deploy

Now with a seed or seed-basic I make the changes to forrest.properties. 
There is a comment you can copy to add the plugins with less typing. 
Both static and dynamic modes work for me: Java 1.4.2 on both Linux and 
Mac OS X. I think I use Java 5 on Windows XP.

The code to use plugins in place has never worked for me with whiteboard 
plugins. I deploy locally any whiteboard plugins I want to use. Are you 
also doing this?

Brian


Mime
View raw message