forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav...." <brightoncomput...@brightontown.com.au>
Subject RE: [heads up] Ant upgraded, please test
Date Fri, 19 May 2006 23:57:50 GMT


> -----Original Message-----
> From: Mark Eggers [mailto:its_toasted@yahoo.com]
> Sent: Saturday, 20 May 2006 6:51 AM
> To: dev@forrest.apache.org
> Subject: Re: [heads up] Ant upgraded, please test
> 
> Another note.
> 
> Falling back to the older version of xml-resolver
> solves the other problem about taking both ANT_HOME
> and $ANT_HOME/bin out of my environment and PATH.
> 
> There is definitely something not friendly to Windows
> in the development version of the resolver, at least
> when it's used with ant.

I'm joining the party here late, I am at revision 399682
And it runs fine on my Windows with the newer xml-resolver
And the newer version of ant. Also using JDK 1.5

Not keen to 'update' to earlier versions at the moment
So guess I'll keep away from head for a bit.

Gav...

> 
> /mde/
> 
> --- Mark Eggers <its_toasted@yahoo.com> wrote:
> 
> > David,
> >
> > I did the switch, and ran into the same problem as
> > before (static site not being built on Windows).
> >
> > I did a network trace while building a static site
> > with both the old resolver and the new resolver.
> >
> > With the old resolver, a forrest site pulled back
> > plugins.xml and the Google logo.
> >
> > With the new resolver, a forrest site attempted to
> > pull back all the DTDs as well.  I haven't analyzed
> > the traffic, so I don't know where the transfer
> > stopped.
> >
> > With the new resolver, a forrest run does not pull
> > back the DTDs (only plugins.xml).
> >
> > I'll dig through the network trace if you think it's
> > useful to find out where the transfer stopped.
> >
> > Mark
> >
> > /mde/
> >
> > --- David Crossley <crossley@apache.org> wrote:
> >
> > > Ferdinand Soethe wrote:
> > > > David Crossley wrote:
> > > >
> > > > > This is just a guess at the problem.
> > > > > I reverted SVN to an older version of
> > > xml-resolver.
> > > >
> > > > > Would a Windows user please 'svn up' and try
> > > again.
> > > >
> > > > Yes, that fixed the problem.
> > >
> > > Thanks. Okay we need to find out how to get more
> > > verbose messages out of the Ant xmlcatalog task
> > > and try the upgrade again. If anyone wants to try
> > > then do this ...
> > >
> > > mv tools/ant/lib/xml-commons-resolver-1.1.jar /tmp
> > > cp
> > lib/core/xml-commons-resolver-1.2-dev-r395116.jar
> > > \
> > >   tools/ant/lib
> > >
> > > Interesting that the newer resolver works for
> > > users in 'forrest run' mode, i.e. in lib/core
> > >
> > > -David
> > >
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam
> > protection around
> > http://mail.yahoo.com
> >
> 
> 
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
> 
> 
> --
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.1.392 / Virus Database: 268.6.1/343 - Release Date: 18/05/2006




Mime
View raw message