forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject [heads up] Ant upgraded, please test
Date Fri, 19 May 2006 01:57:48 GMT
Mark Eggers wrote:
> The only way I've been able to build static sites
> since the upgrade of ant is to turn off validation.
> 
> I'm running on Windows/2000 Professional and jdk
> 1.5.0_06.  I've removed ANT_HOME, all CLASSPATH
> information, and %ANT_HOME%\bin from my path.

As i said in another thread, i can successfully
generate site-author. Other tests such as
./build.sh test are fine too. Docs in plugins are okay.

I do have the same as you regarding no ANT_HOME
or ant bin in PATH. However even with ANT_HOME set
to an old Ant-1.6.2, i still have no problems.
Forrest should be using its own packaged Ant.

I am using Java-1.4 ... could that be the difference?

> When I do that, I get the following error when running
> at the CMD.exe prompt or under Cygwin.
> 
> validate-xdocs:
> 
> BUILD FAILED
> C:\src\forrest\main\targets\validate.xml:146: Could
> not validate document
> C:\src\sites-src\normal\src\documentation\content\xdocs\samples\linking.xml

That is an obscure message. Was there any other information
just before or just after that which mentioned "catalog"?

> Looking at line 146 at validate.xml, it seems that
> this is where the parser is defined.
> 
> <xmlvalidate 
>   failonerror="${forrest.validate.xdocs.failonerror}" 
>   lenient="no" warn="yes" classpathref="forrest.cp" 
>   classname="org.apache.xerces.parsers.SAXParser">
> 
> This class is in xeresImpl-2.8.0, which is in the
> endorsed subdirectory of lib.
> 
> I noticed that -lib was replaced with -cp in the ant
> scripts when ant was changed.  Did this change get
> reflected in all of the forrest scripts?

No. We don't have any such usage in our build scripts.

-David

> If I've missed something, please let me know.
> 
> Thanks,
> 
> /mde/

Mime
View raw message