forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferdinand Soethe <ferdin...@apache.org>
Subject Re: Deploying docs totally quiet
Date Thu, 25 May 2006 12:20:20 GMT

Couple of notes on publishing from Windows XP:

I tried with one changed document.
Build works ok. Deploy does not.
To be sure I tried to manually delete /site-author/work.
That only worked after manually resetting the system and read-only
attributes (with attrib) and even then some files report problems:

> Der Pfad C:\U_Daten\forrest\head\site-author\work\svn-deploy\forrest-docs\pluginDocs\plugins_0_70\org.apache.forrest.plugin.input.OpenOffice.org\sampl
> es\openOfficeEmbeddedImage\zip-openoffice-impress.sxi\file-Pictures\.svn\prop-base\10000000000001A0000001129DD2CF32.png.svn-base
ist zu lang.

This is a path too long error!

Had quite a problem delete these files since del, rmdir, explorer and
others simply refused to. Until I had the idea of moving the whole
work-branch to the root directory. After that everything worked ok.

Conclusion: we should put a warning about this into the instructions.

Not I'm stuck with the problem of interrupted connection-aborts:

> C:\forrest\head\site-author>forrest -f publish.xml deploy -Ddeploy.svn.commit-message="test
docs update"
> ****************************************
> Using Forrest C:\forrest\head
> for Project
> C:\forrest\head\site-author
> ****************************************
> 
> Apache Forrest.  Run 'forrest -projecthelp' to list options
> 
> 
> Buildfile: publish.xml
> 
> deploy.svn:
> svn: REPORT Anfrage fehlgeschlagen auf '/repos/asf/!svn/vcc/default'
> svn: REPORT von '/repos/asf/!svn/vcc/default': Could not read response body: Secure connection
truncated (https://svn.apache.org)
> 
> BUILD FAILED
> C:\forrest\head\tools\forrestbot\core\deploy.xml:159: com.alternatecomputing.jsvn.command.CommandException:
svn: REPORT Anfrage fehlgeschlagen auf '/r
> epos/asf/!svn/vcc/default'
> svn: REPORT von '/repos/asf/!svn/vcc/default': Could not read response body: Secure connection
truncated (https://svn.apache.org)
> 
> 
> Total time: 5 minutes 28 seconds

This may have to do with my atm rather shaky internet connection so I
have postponed this until my provider is back to normal.

Ferdinand







--
Ferdinand Soethe


Mime
View raw message