forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: [jira] Commented: (FOR-492) Inconsistent Line Endings in generated sites
Date Thu, 20 Apr 2006 00:19:26 GMT
Gav.... wrote:
> From: Ross Gardler
> > David Crossley (JIRA) wrote:
> > >
> > > Thanks. I am on UNIX and can see the problem line-endings in your
> > > Windows-generated attachment, e.g. at lines 38 and 39 ...
> > >
> > >      35 </head>^M$
> > >      36 <body>^M$
> > >      37 <div id="container">^M$
> > >      38 <!--+$
> > >      39     | start breadtrail$
> > >      40     +-->^M$
> > >      41 <div class="breadtrail">^M$
> > 
> > I already did a thorought analysis oif this problem - see the linked
> > messages. The above highlights the problem - it is *only* in the
> > comments that are the problem. This is confirmed in the Xalan issue this
> > one depends on.
> 
> Yes, I guess David wanted another confirmation from another Windows user.

Ross' Description of FOR-492 is back-to-front in its
explanation of line-endings. Hence my request on 04/Mar
for an explicit example. We need to change that Description.

> Anyway, seeing as the XALANJ-656 issue has not been updated since January,
> has Anyone tried your suggestion of using FixCRLF in Ant ?
> 
> Do you want me to try it on my system?

I don't see how that will work, as it would just
mangle the rest of the line-endings for Windows users.

It would be better to follow up on the XALAN issue.
I have wanted to for a long time but i couldn't get
anyone to comment on my FOR-492 query. Now we can
point them to further information.

By the way, this issue came up again at the general@xml
mailing list yesterday:
http://marc.theaimsgroup.com/?t=114518424300001

-David

Mime
View raw message