forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin <forr...@kegcl.demon.co.uk>
Subject DOCO testing problems
Date Wed, 12 Apr 2006 17:58:17 GMT
I've been speed reading the list for a while and tried to get
DOCO installed.

First time when it was first announced install was fine but now
I have problems.

1) forrest

.../forrest/whiteboard/doco

forrest run

dispatcherError: 500 - Internal server error 
The contract "content-title" has thrown thrown an exception by resolving raw data from "cocoon://index.title.xml".

dispatcherErrorStack:
 org.xml.sax.SAXParseException: Content is not allowed in prolog.


forrest site
...
* [9/10]    [0/5]     3.571s 3.2Kb   index/index_en.html
X [0]                                     index/xdoc/faq.html   BROKEN:
dispatcherError: 500 - Internal server error
The contract "genericXhtml" has thrown thrown an exception by resolving
raw data from "cocoon://index/xdoc/faq.xml".
...


In a work area I tried forrest seed and enabled dispatcher and it
seems to be dispatcher related.

Unless I've done something wrong being away for a while and forget
something. Yep I enabled dispatcher patch and local deploy plugins.

2) lenya

Was never able to use it before so now I see xdoc editing great.

a) xdoc
http://localhost:9999/doco/authoring/index/xdoc.html

Editor choices BXE / one Form. BXE has the file wrapped in normal
and tag view - couldn't work out how to edit?

Anyway tried "one Form" and file nicely indented with tags. Did a
simple edit and save. Got error:

unfinished element

org.apache.cocoon.ProcessingException: Error calling continuation at
file:/usr/local/java/lenya-
trunk/build/lenya/webapp/lenya/usecases/usecases.js:257:-1 at <map:call>
-
file:/usr/local/java/lenya-
trunk/build/lenya/webapp/lenya/usecases/usecase.xmap:95:39 at
<map:mount> -
file:/usr/local/java/lenya-
trunk/build/lenya/webapp/lenya/usecase.xmap:56:128 at <map:mount> -
file:/usr/local/java/lenya-trunk/build/lenya/webapp/global-
sitemap.xmap:318:105 at <map:mount> -
file:/usr/local/java/lenya-trunk/build/lenya/webapp/sitemap.xmap:620:106

column: -1

line: -1

cause: org.xml.sax.SAXParseException: unfinished element

---
*Do I need a live internet connection to use Lenya / validate xdoc dtd*?

Looking at the source
.../forrest/whiteboard/doco/content/authoring/index/xdoc/index_en.xml
No dtd reference?
Did a quick vi edit of index_en.xml to see the change in Lenya ok.

So I'm puzzled. Thinking Lenya not validating against forrest dtd
catalog but in Lenya? I didn't edit any tags just text so parse error
is wrong.


b) I tried edit of xhtml
http://localhost:9999/doco/authoring/index/anxhtmldoc.html

Get extra edit option Kupu. With a 404 error on save?

Same "unfinnished element" error as above saving with "one Form"

*Wow nice layout with normal view in BXE and I can edit and save!*


c) Tried edit of parent xhtml
http://localhost:9999/doco/authoring/index.html

Kupu edit option same 404 error on save?

*Yes "one Form" I can edit and save!*

*Yes BXE I can edit and save!*

---
Hope my observations are useful and can be confirmed by others so it's
not my setup.

Lenya authoring doco recap:
c) parent xhtml 2 of 3 editors ok
b) xhtml 1 of 3 editors ok
a) xdoc 0 of 2 editors :(

Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

Kevin



Mime
View raw message