forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: [PROPOSAL] Plugin and themes naming convention
Date Sat, 11 Feb 2006 02:46:07 GMT
Thorsten Scherler wrote:
> Ferdinand Soethe escribi??:
> > David Crossley wrote:
> > > Singular for a "plugin" package ...
> > 
> > +1
> > 
> > > org.apache.forrest.plugin.input.fooBar
> > > org.apache.forrest.plugin.input.xhtml
> > 
> > > Plural for a "themes" package ...
> > 
> > +1
> > 
> > simply because the have the capability to contain more than one
> > 
> > > org.apache.forrest.themes.core
> > > org.apache.forrest.themes.backyardGarden
> > 
> > Much in favor or camel case because it is so much better to
> > understand once we get into more complex names.
> > 
> > Perhaps each of us can donate some upper case keys to Thorsten to help
> > with the transition :-)
> 
> jeje
> 
> no, let me explain why from java logic
> org.apache.forrest.plugin.input.PhotoGallery
> would mean there is a class e.g. named PhotoGallery.java in the
> following *path*
> org/apache/forrest/plugin/input/PhotoGallery.java
> 
> What we are doing (given Ross explanation)
> 
> Ross Gardler escribi??:
> > Yeah, I see your point, I interpret it the other way around A package 
> > name relates to a bunch of related classes, a class is not necessarily
> > a 
> > single class (inner classes).
> > So a package name is org.apache.forrest.plugins.input and a class
> > name 
> > is ProjectInfo (for example).
> 
> right now is not conform to the java spec. 
> 
> If we would adopt the dir structure I still argue that the 
> package should be called org.apache.forrest.plugin.input.photoGallery
> since it is more then just a "bunch of related classes". It is a package
> of classes. ;-)
> 
> With camel case we would (logically) prevent that plugins could provide
> components.
> org.apache.forrest.plugin.input.photoGallery.transformation.PhotoGallery
> would be in a dir called:
> org.apache.forrest.plugin.input.PhotoGallery/

The plugin name is not Java related. Any java starts
at src/java directory. So IMO we can use our own
convention for the plugin names.

-David

Mime
View raw message