forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferdinand Soethe <>
Subject Re: [PROPOSAL] Plugin and themes naming convention
Date Fri, 10 Feb 2006 16:54:51 GMT

> Singular for a "plugin" package ...


> org.apache.forrest.plugin.input.fooBar
> org.apache.forrest.plugin.input.xhtml

> Plural for a "themes" package ...


simply because the have the capability to contain more than one

> org.apache.forrest.themes.core
> org.apache.forrest.themes.backyardGarden

Much in favor or camel case because it is so much better to
understand once we get into more complex names.

Perhaps each of us can donate some upper case keys to Thorsten to help
with the transition :-)

> Leaving the existing plugins names as-is.
> That adds to confusion, but too big to change.

Why is it such a big change? I'd change existing names if possible
unless it is really a major effort.

Ferdinand Soethe

View raw message