forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav...." <brightoncomput...@brightontown.com.au>
Subject Re: Dispatcher rc1
Date Sat, 04 Feb 2006 23:19:27 GMT

----- Original Message ----- 
From: "Thorsten Scherler" <thorsten@apache.org>
To: <dev@forrest.apache.org>
Sent: Sunday, February 05, 2006 4:10 AM
Subject: Re: Dispatcher rc1


| El sáb, 04-02-2006 a las 21:58 +0800, Gav.... escribió:
| > ----- Original Message ----- 
| > From: "Gav...." <brightoncomputers@brightontown.com.au>
| > To: <dev@forrest.apache.org>
| > Sent: Saturday, February 04, 2006 8:57 PM
| > Subject: Re: Dispatcher rc1
| >
| > |
| > || Ok, so I got my pili theme working in the new rc1, except...
| > ||
| > || Does the genericMarkup.ft file need altering for rc1 or
| > || is my markup to inlcude it in need of alteration.
| > |
| > | Looking at FOR-787 it has indeed been altered for rc1
| > | so the problem lies with me and my coding then.
| >
| > Actually I solved it, the markup I used in pili.fv was correct.
| > It seems an old version of genericMarkup.ft got put into
| > my /pili/html/ folder.
| >
| > Assuming that the genericMarkup.ft was correct in /common/html/
| > I just removed the old version from my /pili/html/ folder.
| > However I got an Internal Server Error, Dispatcher apparantly
| > could not find it (falling back into common). So I copied this into my
| > /pili/html/ folder and
| > it now works perfect.
| >
| > This brings a new problem though. I thought anything in /*theme*/html/
| > folder is searched for and used first, if not found then fall back to
| > /common/html/ .
| > It seems to not be happening any more.
|
| Actually I found sometimes the same problem. I solved it by restarting
| "forrest run". It is because the locationmap is caching the calls, so if
| there is an entry for the location in the cache, it will be taken.
| Regardless whether you have added it to place that have priority of the
| other.
|
| However, as well I am not 100% sure that *all* locations are matches
| from the fallback list. Could you provide an example where exactly you
| have added the contracts, then I can see what is going on and may fix
| the bug (if it is one).

You are right, I removed the file from my /*theme*/html/ folder, restarted
with a 'Forrest run' and now the one in /common/html/ is being picked up
correctly. I tested further by copying and making obvious alterations
to a few other contracts, these are being picked up in the /*themes*/html/
folder. Removing them causes errors until Jetty is restarted.

I also put images into the /xdocs/images/ folder and these are picked up
no problem. It seems this images folder has priority over the 
/resources/images/
folder. If an image of name 'image1.gif' exists in both locations, the one 
in the /xdocs/images/
folder is the one that is used. This is not the rc1 'theme' type of test you 
wanted carried
out but thought I'd mention it anyway. I am not sure of the correct usage of 
both of these
images folders, or if one is redundant.

|
| Thanks for testing Gav.
|
| Keep up the good work. :)

No problem, as and when I get time. :)

Gav...
|
| salu2
| -- 
| thorsten
|
| "Together we stand, divided we fall!"
| Hey you (Pink Floyd)
|
|
|
|
| -- 
| No virus found in this incoming message.
| Checked by AVG Free Edition.
| Version: 7.1.375 / Virus Database: 267.15.1/250 - Release Date: 3/02/2006
|
| 



-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.375 / Virus Database: 267.15.1/250 - Release Date: 3/02/2006



Mime
View raw message