forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: Forrest 0.7x war throws Execption in Tomcat 4
Date Thu, 19 Jan 2006 16:03:50 GMT
Ferdinand Soethe wrote:
> Today we tried to run our community college application
> (www.bildungsverein.de) in a Tomcat-Server planning to do a load and
> long term run test.
> 
> - Using Forrest 0.7x (current patch) we did
>   forrest war
> - then placed the application on a Tomcat version 4.0
> 
> Unfortunately the test was rather short, after accessing just a few pages the
> application hung after and exception
> 
> java.lang.NoClassDefFoundError: org/w3c/dom/svg/SVGDocument
> 

...

> - Any other ideas what we need to do to fix this?

Tomcat can't find one of the Jars. Looking through the log we see:

org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1243)
       at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
       at
org.apache.batik.dom.svg.SVGDOMImplementation.createDocument(SVGDOMImplementation.java:174)

This implies that the missing class may normally reside in the Batik 
Jar. A quick check of the contents of that jar confirm this to be the case.

So this tells us that Tomcat is unable to see the batik.jar for some reason.

First thing to do is to look to see if that jar is being packaged in the 
WAR. I did a war of our site-author and, as expected, the jar is present 
in WEB-INF/lib

Assuming that it is also present in your war file then I'm afraid this 
is a local installation problem with respect to Tomcat, not a problem 
with Forrest.

Ross


Mime
View raw message