forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Re: Dispatcher quickstart and Photogallery
Date Sun, 29 Jan 2006 21:30:29 GMT
El lun, 30-01-2006 a las 08:09 +1100, David Crossley escribió:
> Thorsten Scherler wrote:
> > David Crossley escribi??:
> > > Tim Williams wrote:
> > > > I've followed the quickstart[1] with the Photogallery plugin and get
> > > > either OutOfMemory exceptions or (if I get silly with a memory
> > > > increase) get a StackOverflowError exception.  I can use the
> > > > Dispacther successfully on a simple seed site though.  I'm not asking
> > > > for anyone to expend resources fully troubleshooting this but if
> > > > someone could confirm/deny the errors I'd appreciate it.
> > > 
> > > I get the same error trying to Dispatcher-enable the
> > > PhotoGallery plugin's own website.
> > > 
> > > I do have a site that actually uses the plugin.
> > > When i try to Dispatcher-enable that site, it fails on
> > > the Gallery parts with "No pipeline matched request: gallery/practice/index_1.xml"
> > 
> > Actually that becomes a faq for v2. ;-)
> > http://marc.theaimsgroup.com/?l=forrest-dev&m=113775018214915&w=2
> > 
> > and
> > 
> > http://issues.apache.org/jira/browse/FOR-738
> 
> Thorsten is referring to Tim's original error and not to
> this new one that i reported. I will report it elsewhere
> as it is not related.
> 
> -David

No, wait David just read the next line (where I refer to this
error): ;-)

> 
> > First I thought that maybe as well FOR-725 but does not seems like it
> > (it worked for me after the following).
> > 


That is the underscore bug, but funny enough it seems to be gone in the
new dispatcher. Further it did not happen to me in the PhotoGallery
anymore, after I commented the site: stuff in the site.xml.  

We still need further testing  
https://issues.apache.org/jira/browse/FOR-725
with the new dispatcher.

salu2

> > When I commend 
> > <!--<forrestPlugins label="Plugins Index" href="site:forrest/plugins"
> > description="Index of Forrest Plugins"/>-->
> > 
> > Then it is working fine. I tried with the new plugins but the site: is
> > still broken there. Meaning the jx:stuff is again broken and we need to
> > fix Davids workaround. :(
> > 
> > Help greatly appreciated.
> > 
> > HTH
> > thorsten
> > -- 
> > thorsten
> > 
> > "Together we stand, divided we fall!" 
> > Hey you (Pink Floyd)
> > 
-- 
thorsten

"Together we stand, divided we fall!" 
Hey you (Pink Floyd)


Mime
View raw message