forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Re: Forrest 0.7x war throws Execption in Tomcat 4
Date Thu, 19 Jan 2006 18:08:46 GMT
El jue, 19-01-2006 a las 18:31 +0100, Ferdinand Soethe escribió:
> Ross Gardler wrote:
> 
> > First thing to do is to look to see if that jar is being packaged in the
> > WAR. I did a war of our site-author and, as expected, the jar is present
> > in WEB-INF/lib
> 
> I checked that. The jar is present and in the jar I found the class
> bvssp.war\WEB-INF\lib\batik-all-1.5.1.jar\org\apache\batik\dom\svg\SVGDOMImplementation.class
> 

...and this is class does extend org/w3c/dom/svg/SVGDocument?

> > Assuming that it is also present in your war file then I'm afraid this
> > is a local installation problem with respect to Tomcat, not a problem 
> > with Forrest.
> 
> OK. So how can I now test this war-file with jetty to make sure that
> it is actually a problem with that Tomcat-Server?

Such errors in tomcat, especially in old versions often have they root
problem in "endorsed" libs like xalan and xerces. You can try to copy
the forrest endorsed lib to the tomcat endorsed lib dir (please google
for this there should be quite a lot of pages describing how to do it).

Other reason may the java version on the server.

I never heard nor know how you can use war with jetty, but to find out I
reckon a mail to jetty-user would be sufficient. ;-) If you know how,
just let us know. ;-)

>  And if so, are
> there any instructions on how to do this (where to put it, how to run
> jetty etc.)

I am afraid not yet here in forrest.

HTH a wee bit

salu2
-- 
thorsten

"Together we stand, divided we fall!" 
Hey you (Pink Floyd)


Mime
View raw message