forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <>
Subject Re: forrestbot problems
Date Tue, 06 Dec 2005 09:36:00 GMT
Tim Williams wrote:
> On 12/5/05, David Crossley <> wrote:
>>Ross Gardler wrote:
>>>Tim Williams wrote:
>>>>David Crossley wrote:
>>>>>Tim Williams wrote:
>>>>>>David Crossley wrote:
>>>>>Hmmm, i wish that someone else would try it.
>>>>Me too.  I don't doubt though that I'm doing something wrong -- just
>>>>can't figure out what it is.  I ran through it again on my linux box
>>>>and the issue is exactly the same as I've been describing so it
>>>>doesn't appear to be a windows thing.
>>>I just tried it (Windows XP + Cygwin). I get the same problem.
>>>I've not seen either of you comment on the Xalan issue that we have come
>>>up against before (see my earlier mails in this thread). Now that I have
>>>done a test I can confirm that I am seeing the same effects, at least
>>>with respect to the inconsistent line endings.
>>>Top see the problem, just open up a generated file and you'll find that
>>>comments have different line endings to all other content. For example:
>>><div id="top">^M
>>>    |breadtrail
>>>    +-->^M
>>><div class="breadtrail">^M
>>So Tim is this the issue that you are seeing
>>or is it something else?
> That does appear to be why all of the files have changed.  I'm not
> sure if there's more than one issue or what though.  I don't know how
> this could result in the authorization failure error I was getting.

To fix the above we need to use the FixCRLF task in ANT [1], at last 
until the bug in Xalan is fixed. I used this in the plugin build.xml to 
fix the same problem.

I have no idea about the authorisation stuff I;m afraid.



View raw message