forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Using plugins with forrest as webapp
Date Wed, 07 Dec 2005 02:35:22 GMT
Ross Gardler wrote:
> Claus Bech Rasmussen - TELMORE wrote:
> >I guess I must be missing something here - could anyone provide a
> >pointer?
> 
> This is a known issue with no current workaround [1], it is scheduled to 
> be fixed in the next release.
> 
> We'd welcome your help, it should be relatively easy to fix, but none of 
> the current devs are using Tomcat in webapp mode so this is waiting for 
> someone to fix it.
> 
> We will, of course help point you in the right direction.
> 
> With that in mind here is a starter...
> 
> I've not examined the problem, but I would suggest that the "webapp" 
> target in our build.xml is failing to copy across the relevant plugin 
> files into a usable location. If you fancy tackling this I would sugest 
>  becoming familiar with how the webapp is currently built.

Well i use a local full Jetty server for testing webapps.
Doing the test that Claus tried, i.e. 'forrest seed war'
works fine for me in Jetty. So the plugins are being added
properly.

Claus, try unpacking the WAR file to ensure that your
plugin is present. I did this ...

cd /tmp/foo
jar tf my-project.war | grep plugins
...
build/plugins/org.apache.forrest.plugin.output.pdf/
...

> This may be a good issue to tackle on Forrest Friday [2] (this coming 
> Friday) when a dev is online to help debug the problem (I'll be online 
> on and off during the day, but almost certainly from about 3pm UTC for a 
> good few hours.
> 
> Ross
> 
> 
> [1] http://issues.apache.org/jira/browse/FOR-735
> [2] http://forrest.apache.org/forrest-friday.html

Mime
View raw message