forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ross Gardler (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FOR-735) Plugins are not correctly deployed in webapp mode
Date Wed, 07 Dec 2005 06:14:09 GMT
    [ http://issues.apache.org/jira/browse/FOR-735?page=comments#action_12359545 ] 

Ross Gardler commented on FOR-735:
----------------------------------

The "webapp" target does not include the plugin files, but the "war" target does:

WORKAROUND:

Build the war file with "forrest war" and deploy that instead. Your servlet engine should
unpack it when it is first used, but you could always unpack manually if necessary.

> Plugins are not correctly deployed in webapp mode
> -------------------------------------------------
>
>          Key: FOR-735
>          URL: http://issues.apache.org/jira/browse/FOR-735
>      Project: Forrest
>         Type: Bug
>   Components: Plugins (general issues), Core operations, Launch servlet WAR
>     Versions: 0.7
>  Environment: Forrest 0.7 running as a webapp under Tomcat 5.0.28 on JDK  1.5.0_01 on
Debian Linux.
>     Reporter: Gunther Sablon
>     Priority: Critical
>      Fix For: 0.8-dev

>
> (At this point I didn't try this scenario step by step any more; basically it is what
we did to setup the site, except that we copied our project data from forrest 0.6 before trying
the pdf links)
> - run forrest webapp to create an empty webapp
> - configure Tomcat to run the webapp (we did it by creating a context descriptor and
put it onder Tomcat's config directory)
> - the pdf links give an error "Resource Not Found"

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message