forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Williams <william...@gmail.com>
Subject Re: forrestbot problems
Date Wed, 30 Nov 2005 01:37:35 GMT
On 11/29/05, David Crossley <crossley@apache.org> wrote:
> Tim Williams wrote:
> > I've still never been able to update our public site with Forrestbot.
> > I periodically retry, thinking I'm doing something wrong but no luck.
> > It consistently fails in the deploy phase of the instructions in /etc.
> >  I've pasted the output below.  We've gone through this before
> > unsuccessfully but I'd really like to be able to get this working.
>
> Have you tried to completely delete the site-author/build/forrest-docs/
> directory. Should not be needed, but perhaps your forrestbot-built
> docs have become corrupted somehow.

Yes.  I've tried forrest clean and manually deleted.

> > Because of the Authorization Fails error that I get towards the end I
> > decided to see if I could manually update the site by committing a
> > single set (pdf+html) of changes on a single document.  That too
> > failed because of "inconsistent line endings" -- maybe that
> > authorization thing is masking a line-ending problem?  Or, maybe I've
> > got multiple problems?
>
> Would you please explain in more detail what you tried there.
> I don't understand. Did you do a normal build with
>  cd site-author
>  forrest
>  cp build/site/index.html ../../forrest-site
>  cd ../../forrest-site
>  svn diff index.html
>  svn commit index.html

No, I haven't tried a standard forrest site on my own.  What I tried
was committing what forrestbot had apparently already checked out in:
"site-author\work\svn-deploy\forrest-docs\"


> You should not be getting line-endings issues.
> I will wait for your further detail above, then we
> can investigate that issue.
>
> I just verified the "forrest-site" repository. There we some
> with incorrect svn:eol-style problems and consequently
> had line-endings issues. The "abs-linkmap" was one of those.
>
> More below ...
>
> > Any help would be appreciated, I've had this problem too long now...
> >
> > --tim
> >
> > ******************************************************
> >
> > C:\src\apache-forrest-trunk-s\site-author>forrest -f publish.xml deploy -Ddeploy
> > .svn.commit-message="another forrestbot attempt"
>
> Forget the "-Ddeploy ..." part, as it is busted.
>
> > Apache Forrest.  Run 'forrest -projecthelp' to list options
> >
> >
> > Buildfile: publish.xml
> >
> > deploy.svn:
> > Copying 400 files to C:\src\apache-forrest-trunk-s\site-author\work\svn-deploy\f
> > orrest-docs
> > svn: warning: 'broken-links.xml' is already under version control
> > svn: warning: 'forrest-issues.html' is already under version control
>   ... [ snip for brevity ]
> > svn: warning: 'forrest-friday.html' is already under version control
> > svn: warning: 'forrest-issues.pdf' is already under version control
> > svn: warning: 'pluginDocs\plugins_0_70\index.pdf' is already under version contr
> > ol
> > svn: 'M     pluginDocs\plugins_0_70\org.apache.forrest.plugin.internal.IMSManife
> > st\repositoryCommand\getSCO\HowTo\repositoryURI\www.burrokeet.org\repositoryData
> > ' is not a working copy
>
> I don't know what that is about. Those docs are not handled
> by forrestbot nor the "site-author" build. The pluginDocs
> have their own deployment mechanism. So this is supporting
> my suggestion above to remove the site-author/build/forrest-docs/

Yeah, I have done that.  Actually, in the many times that I've tried
forrestbot, I've completely deleted and rechecked out the entire
trunk.  So cleanliness, I think, isn't likely an issue.

> > Result: 1
> > svn: Commit failed (details follow):
> > svn: CHECKOUT of '/repos/asf/!svn/ver/332744/forrest/site/abs-linkmap': authoriz
> > ation failed (https://svn.apache.org)
> >
> > BUILD FAILED
> > C:\src\apache-forrest-trunk-s\tools\forrestbot\core\deploy.xml:157: com.alternat
> > ecomputing.jsvn.command.CommandException: svn: Commit failed (details follow):
> > svn: CHECKOUT of '/repos/asf/!svn/ver/332744/forrest/site/abs-linkmap': authoriz
> > ation failed (https://svn.apache.org)
>
> I don't know what this is about. Lets wait on your further
> info from above.

Ok, I've given the further info you've asked for hopefully it's
helpful.  I want to mention too that I've got a Linux (fedora core)
box that is my file/print server at home and I've tried forrrestbot on
it too to no avail -- I don't remember if the errors are exactly the
same or not though.
--tim

Mime
View raw message