forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <>
Subject Re: deployed plugins with wrong version number
Date Fri, 25 Nov 2005 06:48:39 GMT
Ross Gardler wrote:
> David Crossley wrote:
> >Ross Gardler wrote:
> >>David Crossley wrote:
> >>
> >>>I wonder if it is because there in no "unversioned"
> >>>plugin in the 0.7 directory. At 0.7 release time
> >>>perhaps we needed to copy the unversioned ones there too.
> >>
> >>Yes, that will be it, I'll look into this ASAP. Thanks.
> >
> >I tried this by:
> >cd forrest-site/plugins/0.7/
> >svn cp 
> >
> >svn commit
> >... then waited for the hourly cronjob to 'svn update' our site.
> >
> >Then tried again with forrest_07 and same problem that was
> >reported above.
> >
> >I noticed that it is trying to retrieve:
> >
> >... perhaps needs /0.7/ in that empty space.
> Thanks David. I'll have to dig into the build files to see what is 
> happening. Probaboly won't have the time until the end of the week at 
> the earliest.

I did this today and it now works for me with forrest_07_branch.

[main]$ svn diff var/pluginlist2fetch.xsl 
Index: var/pluginlist2fetch.xsl
--- var/pluginlist2fetch.xsl    (revision 329512)
+++ var/pluginlist2fetch.xsl    (working copy)
@@ -46,7 +46,7 @@
          <target name="fetch-unversioned-plugin" unless="versioned-plugin.present">
             <echo>Versioned plugin unavailable, trying to get versionless plugin...</echo>
             <get verbose="true" usetimestamp="true" ignoreerrors="true">
-               <xsl:attribute name="src"><xsl:value-of select="plugin[@name=$plugin-name]/@url"
/>/<xsl:value-of select="$plugin-name" />.zip</xsl:attribute>
+               <xsl:attribute name="src"><xsl:value-of select="plugin[@name=$plugin-name]/@url"
/>/<xsl:value-of select="$forrest-version" />/<xsl:value-of select="$plugin-name"

So our plugin deployment process needs to put a copy
of the plugin into the specific version directory, e.g.
in plugins/0.8-dev/ and we need to manually add them to
the plugins/0.7/ directory.

Perhaps we then don't need the unversioned plugins at
the plugins/ directory, rather only have them in the
specific sub-directory.

> In the meantime we need to advise users to add a version number as you 
> discovered.

I am surprised that we are not getting more pleas for
help from users of the 0.7 projectInfo plugin.


View raw message