forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ross Gardler (JIRA)" <j...@apache.org>
Subject [jira] Commented: (FOR-734) Document new forrest.properties.xml file
Date Tue, 22 Nov 2005 17:01:41 GMT
    [ http://issues.apache.org/jira/browse/FOR-734?page=comments#action_12358266 ] 

Ross Gardler commented on FOR-734:
----------------------------------

Naming Convention
================

The naming convention for properties is as follows:

COMPONENT.PROPERTY[.TYPE]

where:

COMPONENT is one of:

- 'core' for a core property exposed by Forrest
- the name of a project that exposes the property
- the name of the plugin that exposes the property

PROPERTY is a human readable name for the property

TYPE is an optional indicator of the type of property value. It does not restrict the values
the property can accept and is only intended as an aid to the humans reading the property
name.

> Document new forrest.properties.xml file
> ----------------------------------------
>
>          Key: FOR-734
>          URL: http://issues.apache.org/jira/browse/FOR-734
>      Project: Forrest
>         Type: Sub-task
>   Components: Documentation and website, Core operations
>     Versions: 0.8-dev
>     Reporter: Ross Gardler
>     Priority: Minor

>
> Documentation for this issue should include:
> - details gleaned from FOR-888
> - an entry in status.xml
> - notes in plugins docs

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message