forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gav...." <brightoncomput...@brightontown.com.au>
Subject Re: V2 observations
Date Mon, 28 Nov 2005 13:50:31 GMT
From: "Cyriaque Dupoirieux" <Cyriaque.Dupoirieux@pcotech.fr>



| Gav.... a écrit :
|
| >Hi All,
| >
| >A couple of observations, these may be bugs or may be me so I'll check 
here
| >first.
| >
| >1. When I did a seed-v2 and then forrest run , creating an index.fv and 
then
| >altering it made
| >no difference after refreshing the browser. When creating a forrrest 
site,
| >this did make
| >a difference.
| >
| >
| Can you try something like : Ctrl + F5 to force the page regeneration,
| We are some to work with dispatcher and noone told there was such a
| problem...

Yes, I did try that at the time, (as well as IE) I also tried it in Firefox 
and Opera
with no success in any, but I will have another go tomorrow.

|
| >2. After removing index.fv from xdocs directory, rebuilding and 
reuploading,
| >index.html
| >still shows as though index.fv were still there (
| >http://apache.minitutorials.com/ ) , no menus
| >etc...

I will re-do this in case I missed something.

| >
| >3. index.fv provided with /samples/ has this for the footer feedback
| >contract :-
| >
| ><forrest:contract name="siteinfo-feedback">
| >          <forrest:properties contract="siteinfo-feedback">
| >            <forrest:property name="siteinfo-feedback">
| >              <feedback to="webmaster@foo.com"
| >                href="mailto:webmaster@foo.com?subject=Feedback&#160;" >
| >                Send feedback about the website to:
| >              </feedback>
| >            </forrest:property>
| >          </forrest:properties>
| >        </forrest:contract>
| >
| >The code this produces is :-
| >
| ><div id="siteinfo-feedback">
| >                Send feedback about the website to:
| >              <a id="feedbackto"
| >href="mailto:webmaster@foo.com?subject=Feedback samples/index.html"><a
| >href="mailto:webmaster@foo.com">webmaster at
| >   foo.com</a></a></div>
| >
| >which is incorrect nesting of the <a> element and also multiple 
declarations
| >of the href and mailto when there is no need. Should this not read
| >
| ><div id="siteinfo-feedback">
| >                Send feedback about the website to:
| >              <a id="feedbackto"
| >href="mailto:webmaster@foo.com?subject=Feedback
| >samples/index.html"></a></div>
| >
| >Where is the extra.. <a href="mailto:webmaster@foo.com">webmaster at
| >foo.com</a> ..coming from ??
| >
| >
| I don't know, but I had already seen this problem.
| Generally, it seems that some links are rewritten whereas they shouldn't.
| Can you create a bug in Jira please.

Issue created.

|
| >4. Default sizing seems to be 10px which looks rather small , menu items 
and
| >'search the site with google' etc are at either 80, 85, or 90 percent of
| >that and so are unreadable. This is of course a minor issue in the grand
| >scheme of getting v2 working but one would of thought the site produced
| >should look similar to the forrest.apache.org live site.
| >
| >
| Correct, Pelt theme has still several layout problems, I am working on 
them.
| At the moment, I have lots of problems with the branding-fontsize.ft
| contract...
| If you want to have a layout nearly correct, please add this contract to
| your fv file. (it will initialise the default size to 16px If I remember
| when the page is loaded)

I will take a look thanks, a quick look suggests implementing this will
override inline CSS with Javascript ??

|
| >5. In the inline CSS of the /samples/index.html page there is produced a
| >wierd and non-compliant use of code when ever the  background-image url 
is
| >used.
| >For instance multiple times there are instances of :-
| >
| >#header .round-top-left-small {
| >    background-image:
| 
 >url(../themes/images/roundcorner-t-l-5-bgFFFFFF-stroke000000-fg000000.png);<a
| 
 >href="../themes/images/roundcorner-t-l-5-bgFFFFFF-stroke000000-fg000000.png">
| ></a>;
| >    background-repeat: no-repeat;
| >    background-position: top left;
| >}
| >
| >This occurs on every instance of when an image is referenced using the
| >background-image: url .
| >The extra :-
| >
| ><a
| 
 >href="../themes/images/roundcorner-t-l-5-bgFFFFFF-stroke000000-fg000000.png">
| ></a>;
| >
| >is neither required nor compliant.

I created an Issue for this also.

When I get time to get back to looking at issues I will look at these, but 
have not
forgotten the one or two I am working on already.

Gav... 



-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.362 / Virus Database: 267.13.8/184 - Release Date: 27/11/2005



-- 
This message was scanned for spam and viruses by BitDefender.
For more information please visit http://linux.bitdefender.com/



Mime
View raw message