forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ross Gardler <rgard...@apache.org>
Subject Re: svn commit: r327750 - /forrest/zone/test-sources/apache-projects/src/documentation/content/xdocs/index.xml
Date Sun, 23 Oct 2005 14:46:07 GMT
David Crossley wrote:
> Ross Gardler wrote:
> 
>>David Crossley wrote:
>>
>>>Ross Gardler wrote:
>>>
>>>
>>>>>Author: crossley
>>>>>Date: Sat Oct 22 22:10:09 2005
>>>>>New Revision: 327750
>>>>>
>>>>>URL: http://svn.apache.org/viewcvs?rev=327750&view=rev
>>>>>Log:
>>>>>The side-panel auto navigation is not working
>>>>>so add a temporary list to the index page.
>>>>>Perhaps this front list should be a generated table.
>>>>
>>>>It works when using "forrest site" or "forrest run". However, it seems
>>>>that Cocoons cache is getting in the way on "forrest run" since changes 
>>>>to the locationmap are only shown if forrest is rerun.
>>>
>>>
>>>I see that the docs get generated with "forrest site"
>>>projectDetails.spamassassin.html
>>>etc.
>>>
>>>However, the left-hand panel only has two entries
>>>under the "Projects => All", expected six.
>>
>>I suspect you are using the old version of the projectInfo plugin. Do 
>>"ant local-deploy"
> 
> 
> Then doesn't it need to be deployed to the website so that
> forrestbot can use it. Remember that forrest-trunk gets a
> 'build clean' every hour, so the plugin will get re-installed.

Yes, but there is a problem with the deploy at present since the docs 
aren't building. I'm in the process of fixing it, but I'm on Sunday 
afternoon work rate ;-)

>>Having said that, I've changed the apache-projects site because the 
>>problem you describe does exist when building with forrestbot. You can 
>>see the intended behaviour if you do forrest site or forrest run on the 
>>project info docs.
> 
> 
> With the current forrestbot-built site, we cannot see any
> project descriptions anymore.

Hmmmm...

That must be something to do with the extra CSS. The text is there, but 
it is in white. This works on forrest run, so I'm not sure why this is 
happening (yet).

Ross

Mime
View raw message