forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Addi <a...@rocktreesky.com>
Subject Re: [jira] Updated: (FOR-180) Update forrestbar to be installablein Mozilla Firefox 0.9
Date Mon, 17 Oct 2005 17:06:56 GMT
Also, in this patch I "versioned" the ForrestBar extension to version
0.7.  I was thinking that we could match the ForrestBar version to the
current version of Forrest.  I have two reasons for this thinking: 1) I
have a link in the toolbar that links to Current Docs so the ForrestBar
version number will tell you which version of the Docs it is pointing to
and this would lead to 2) every release of Forrest we should revisit
ForrestBar to update the Docs link but also to verify continuing
compatibility with browsers so we don't let it fall behind again. Does
this seem reasonable?  I am also looking at getting ForrestBar on the
official Mozilla extensions site so that updates will be automatic for
users.  Is there any problem with this that I'm not aware of?

I am also continuing to play with it to try and get it to work in
Netscape 8.  I tried to put stuff that I thought would be most useful to
us but if something needs to be added, it is really simple to do by
looking at the chrome/content/forrestbarOverlay.xul file (or just ask on
the list and I'll add it).

- Addi

Addison Berry (JIRA) wrote:

>     [ http://issues.apache.org/jira/browse/FOR-180?page=all ]
>
>Addison Berry updated FOR-180:
>------------------------------
>
>    Attachment: forrestbar.diff
>                forrestbar.xpi
>                forrestbar.xml.diff
>
>This new extension will work with Mozilla 1.x and Firefox 0.9 - 1.5 versions.  The .xpi
file attached is the one built running the forrestbar target.  I'm not sure how we get the
.xpi file that is on the web site - if it is built or just put on the server in it's final
form - so I included it here.
>
>  
>



Mime
View raw message