forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Fixing problems with v2
Date Fri, 21 Oct 2005 09:26:12 GMT
Thorsten Scherler wrote:
> Cyriaque Dupoirieux escribi??:
> > Thorsten Scherler a ??crit :
> > >Cyriaque Dupoirieux escribi??:
> > >  
> > >
> > >>I have the following error :
> > >>
> > >>X [0] samples/linking.html BROKEN: 
> > >>D:\duc\forrest\build\plugins\org.apache.forrest.plugin.internal.structurer

> > >>(Ac
> > >>
> > >>c??s refus??) ?
> > >>
> > >>Since Monday,
> > >>(even on a forrest seed...)
> > >>I think I am going to delete my whiteboard directory and my build directory
and update svn.
> > >>WDT ?
> > >>    
> > >>
> > Ok, I made what I wrote and try on a new forrest seed, here are my 
> > conclusions :
> > 
> >     * forrest run is nearly OK,
> >     * forrest site gives the error :
> >           o
> > 
> > X [0] samples/linking.html BROKEN: 
> > D:\duc\forrest\build\plugins\org.apache.forrest.plugin.internal.structurer 
> > (Acc??s refus??) ?
> > 
> >    Throsten - or anyone using structurer, - can you try forrest site and 
> > tell me (if you have time.)
> 
> http://issues.apache.org/jira/browse/FOR-675
> 
> Please see this issue and *a lots* of FIXME notes in the structurer. 
> 
> "forrest site" is *not* expected to work!!! We need to resolve this
> issue that v2 supports static forrest again. 

Hmmm, that is not correct. That FOR-675 affects both
'forrest run' and 'forrest site' with the same effects:
... the broken "site:" and "ext:" links.

As far as i know it does not affect anything else.

So i don't know why you needed to comment-out all the
linkrewriter stuff. That just makes it hard to test
to see if the bug is still present.

> We need to add a strip_namespaces.xsl before returning site.xml to have
> a workaround for this issue.

Yes.

-David

Mime
View raw message