forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ferdinand Soethe <ferdin...@apache.org>
Subject Re: Cleaning up html-processing
Date Tue, 04 Oct 2005 13:41:02 GMT


Ross Gardler wrote:

> I also was unable to find a border="1" sing search tools. Perhaps we can
> work with Ferdinand to solve this on todays Forest Tuesday.

Thanks. After Kevin's posting I got suspicious and tried a freshly
seed site this morning. Border = 1 no longer shows and class is
properly passed through.

Sorry for the wild goose chase. What I still don't know is why this
doesn't work with my existing site (set up just a few weeks ago).
Since stuff like this has happened a few times I almost feel like I
should do all development on freshly seeded installations.

But while we are at it Kevin has uncovered a programming error for
tables without class that I created but don't understand:

> <html>
> <head><title>Tables</title></head>
> <body>
> <h1>Borders?</h1>
> <table><tr><td>Forrest Table</td></tr></table>
> <table class="foo" cellpadding="5"><tr><td>Foo Table</td></tr></table>
> </body>
> </html>
> 
> Generated Forrest page had no borders on either table
> and no expected ForrestTable class on <table> with no class.


Even though class is empty and

"<xsl:value-of select="@class"/>" will show ""

the test condition

<xsl:when test="@class = ''">

does not seem to work properly so all tables are now
treated like in the otherwise branch.

--
Ferdinand Soethe


Mime
View raw message