forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Re: Fixing problems with v2
Date Fri, 21 Oct 2005 10:46:22 GMT
El vie, 21-10-2005 a las 20:38 +1000, David Crossley escribió:
> Thorsten Scherler wrote:
> > David Crossley escribi??:
> > > Thorsten Scherler wrote:
> > > > Cyriaque Dupoirieux escribi??:
> > > > ...
> > > > >    Throsten - or anyone using structurer, - can you try forrest site
and 
> > > > > tell me (if you have time.)
> > > > 
> > > > http://issues.apache.org/jira/browse/FOR-675
> > > > 
> > > > Please see this issue and *a lots* of FIXME notes in the structurer. 
> > > > 
> > > > "forrest site" is *not* expected to work!!! We need to resolve this
> > > > issue that v2 supports static forrest again. 
> > > 
> > > Hmmm, that is not correct. That FOR-675 affects both
> > > 'forrest run' and 'forrest site' with the same effects:
> > > ... the broken "site:" and "ext:" links.
> > 
> > Yes and no. The linkmap.html is used to crawl. Now if you have a site
> > that is using heavily site:bla then the links on the linkmap are all
> > NULL. That let forrest site directly fail. forrest run instead do not
> > need the linkmap.xml.
> 
> Okay, sorry, i see what you are saying now.
> Hmmm, i don't remember that happening in the
> earlier discovery of this FOR-675 issue.
> Maybe i am delirious.

Actually it was always like that. You are totally right in saying 
> > > 'forrest run' and 'forrest site' with the same effects:
> > > ... the broken "site:" and "ext:" links.

That is still the case. Only that forrest run needs not to crawl this
links.

> > > As far as i know it does not affect anything else.
> > > 
> > > So i don't know why you needed to comment-out all the
> > > linkrewriter stuff. That just makes it hard to test
> > > to see if the bug is still present.
> > 
> > ??? What do you mean?
> 
> I thought that i had fixed the bug and started testing
> in the various scenarios. Testing it in the new structurer
> plugin is hard because the use of linkrewriter transformer
> is commented-out.
> 
> Never mind the bug is not yet fixed.
> 

No problem, mate. I will uncomment it again. No problem. ;-)

Thanks for all your help.

salu2
-- 
thorsten

"Together we stand, divided we fall!" 
Hey you (Pink Floyd)


Mime
View raw message