forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Re: Fixing problems with v2
Date Fri, 21 Oct 2005 09:31:37 GMT
El vie, 21-10-2005 a las 19:26 +1000, David Crossley escribi├│:
> Thorsten Scherler wrote:
> > Cyriaque Dupoirieux escribi??:
> > ...
> > >    Throsten - or anyone using structurer, - can you try forrest site and 
> > > tell me (if you have time.)
> > 
> > http://issues.apache.org/jira/browse/FOR-675
> > 
> > Please see this issue and *a lots* of FIXME notes in the structurer. 
> > 
> > "forrest site" is *not* expected to work!!! We need to resolve this
> > issue that v2 supports static forrest again. 
> 
> Hmmm, that is not correct. That FOR-675 affects both
> 'forrest run' and 'forrest site' with the same effects:
> ... the broken "site:" and "ext:" links.

Yes and no. The linkmap.html is used to crawl. Now if you have a site
that is using heavily site:bla then the links on the linkmap are all
NULL. That let forrest site directly fail. forrest run instead do not
need the linkmap.xml.

> As far as i know it does not affect anything else.
> 
> So i don't know why you needed to comment-out all the
> linkrewriter stuff. That just makes it hard to test
> to see if the bug is still present.

┬┐? What do you mean?


> 
> > We need to add a strip_namespaces.xsl before returning site.xml to have
> > a workaround for this issue.
> 
> Yes.
> 
> -David

salu2
-- 
thorsten

"Together we stand, divided we fall!" 
Hey you (Pink Floyd)


Mime
View raw message