forrest-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thorsten Scherler <thors...@apache.org>
Subject Re: Problems using old views.
Date Thu, 13 Oct 2005 17:22:58 GMT
Grr, I think it is:

<view-internal>@forrest.home@/build/plugins/@project.view.internal.plugin@</view-internal>

<view-themes>@forrest.home@/build/plugins/@project.theme.plugin@/resources/views</view-themes>

of the forrestcore.xconf

I think someone changed @project.theme.plugin@ to the new plugins. Just
try in your forrest.properties:
project.view.internal.plugin=org.apache.forrest.plugin.internal.view
project.theme.plugin=org.apache.forrest.plugin.internal.view

HTH
salu2

El jue, 13-10-2005 a las 19:18 +0200, Thorsten Scherler escribió:
> Hmm, it seems you have a similar problem like Cyriaque, but the other
> way around. :(
> 
> El jue, 13-10-2005 a las 18:10 +0100, Kevin escribió:
> > I've done a fresh svn checkout after having problems with svn up.
> > Now at #314981.
> > 
> > cd main
> > build.sh clean; build.sh
> > 
> > cd ../etc
> > (noticed views-old.sh refers to old view plugins)
> > views-old.sh
> > 
> > cd /my/work
> > forrest seed-basic
> > 
> > (noticed forrest.properties: project.required.plugins refers to)
> > org.apache.forrest.plugin.input.viewHelper.xhtml.ls
> > org.apache.forrest.plugin.output.themes,
> > org.apache.forrest.plugin.internal.structurer
> > 
> > (changed to use)
> > org.apache.forrest.plugin.input.viewHelper.xhtml.ls
> > org.apache.forrest.plugin.output.viewHelper.xhtml,
> > org.apache.forrest.plugin.internal.view
> > 
> > (still the same org.apache.forrest.plugin.input.viewHelper.xhtml.ls?)
> 
> Yes still that one *should* be independent.
> 
> > forrest site
> > 
> > (gives error)
> > 
> > X [0]                                     linkmap.html
> > BROKEN: /usr/java/forrest/build/plugins/org.apache.forrest.plugin.internal.structurer/resources/views/default.fv
(No such file or directory)
> > Total time: 0 minutes 10 seconds,  Site size: 0 Site pages: 0
> > 
> > I can't see if I've done something wrong to reference structurer?
> 
> Yeah, that is wrong, but with the config you have given that should not
> be.
> 
> > Looks like maybe something in core uses structurer? Could someone
> > help with the revision #? to go back to a working version. Thanks.
> > It hurt last time I did it. Iterative trial and error on dial up :(
> 
> Sorry, ATM i am not having even that. I will be off now and maybe will
> find the answer tonight. I will report back tomorrow. 
> 
> > Do I need to stay at the core rollback revision #? and just 'svn up'
> > for old view plugins? 
> 
> Old view plugins should not being touched anymore, so I wonder why that
> could happen. You can update normally because we nailed down the
> revision for views.
> 
> > 
> > I know old views aren't really supported so no need for a jira. I
> > just hope I can get back to an old working version in core and old
> > view plugins. Thanks.
> 
> Jupp, will do everything to help you there. Views v1 *are* and will be
> supported! V2 not yet. ;-)
> 
> salu2
-- 
thorsten

"Together we stand, divided we fall!" 
Hey you (Pink Floyd)


Mime
View raw message